(PAT 1101) Quick Sort (递推)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

解题思路

这题和快速排序没什么关系

给出一个数组,判断某位数左边所有元素是否都小于它,右边所有元素是否都大于它

如果暴力搜素的话必然会超时,我们这里采用递推法

从左向右依次输出目前位置最大的元素,从右向左依次输出目前位置的最小元素

可以得到两个数列

1 3 3 4 5

1 2 2 4 5

然后判断该位目前最大元素是否小于等于他,最小元素是否大于等于他

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXN = 100010;
long int numbers[MAXN];
long int forwards[MAXN];
long int backs[MAXN];
int  N;
int main() {
	scanf("%d", &N);
	for (int i = 0; i < N; ++i) {
		scanf("%d", &numbers[i]);
	}
	//正推
	int biggest = numbers[0];
	forwards[0] = numbers[0];
	for (int j = 1; j < N; ++j) {
		forwards[j] = forwards[j - 1];  //递推
		if (numbers[j] > biggest) {
			biggest = numbers[j];
			forwards[j] = biggest;
		}
	}
	//逆推
	int smallest = numbers[N - 1];
	backs[N-1] = numbers[N - 1];
	for (int k = N - 2; k >= 0; --k) {
		backs[k] = backs[k+1];
		if (numbers[k] < smallest) {
			smallest = numbers[k];
			backs[k] = smallest;
		}
	}
	vector<long int> res;
	for (int i = 0; i < N; ++i) {
		if (numbers[i] >= forwards[i] && numbers[i] <= backs[i]) {
			res.push_back(numbers[i]);
		}
	}
	
  cout << res.size() << endl;
	for (int i = 0; i < res.size(); ++i) {
			cout << res[i];
			if(i < res.size()-1){
			  cout<<" ";
			}
	}
	cout<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值