Radar Installation POJ - 1328

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

 

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题目大意:在一个直的海岸线上,海岸线上边有N个小岛,每个雷达的范围是半径为M的圆,你需要找到最少需要多少个雷达能把小岛全部覆盖,如果不能全部覆盖则输出-1;给的数据,第一行N为小岛的数量,M是雷达范围,后N行是小岛的坐标,雷达全部都在海岸线上即x轴上。

解题思路:找到每个小岛在雷达范围的左端点和右端点,然后按右端点进行排序,如果后一个的左端点大于前一个的右端点,则需要加一个雷达;如果有小岛的Y坐标大于M直接输出-1,跳过后面的。

代码如下:

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
struct note
{
    double l,r;
}e[10101];
bool cmp(note x,note y)
{
    return x.r<y.r;
}
int main()
{
     int n,m,k=1,i;
     while(~scanf("%d%d",&n,&m)&&(n||m))
     {   int flag=0;
         for(i=0;i<n;i++)
            {   double a,b;
                scanf("%lf%lf",&a,&b);
                if(b>m) flag=1;
                e[i].l=a-sqrt(m*m-b*b);//确定小岛的左边最大范围,
                e[i].r=a+sqrt(m*m-b*b);//右边
            }
        if(flag)
        {printf("Case %d: -1\n",k++);  //有小岛超过雷达范围直接输出-1
         continue;
        }
        sort(e,e+n,cmp);               //按右端点进行排序
        int sum=1;
        double mx=e[0].r;
        for(i=1;i<n;i++)
        {
            if(e[i].l>mx)             //后一个左端点大于前一个的右端点
            {
                mx=e[i].r;
                sum++;
            }
        }
        printf("Case %d: %d\n",k++,sum);
     }
     return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值