I - Largest Rectangle in a Histogram HDU - 1506

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题目大意:

就是问最大的矩形面积。因为要形成矩形所以在一个数柱周围的都不能低于他,然后这个柱子的高乘上能形成矩形的个数就是这个数柱形成的最大矩形面积,把每一个的计算出来找到最大的即可,一般的暴力会超时,所以要用dp简化一下。代码如下

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    long long high[110000];
    while(~scanf("%d",&n) && n)
    {
        int i,j;
        high[0]=0;high[n+1]=0;
        for(i=1; i<=n; i++)
            scanf("%lld",&high[i]);
        int a[110000],b[110000];
        a[1]=1;               //往左边找
        b[n]=n;               //往右边找
        for(i=2; i<=n; i++)
        {
            int t=i;
            while (t>1 && high[i]<=high[t-1])   //用前一个数据减少运算
                t=a[t-1];
            a[i]=t;
        }
        for(i=n-1; i>=1; i--)
        {   int t=i;
            while (t<n && high[i]<=high[t+1])
                t=b[t+1];
            b[i]=t;
        }
        long long  maxx=-100;
        for(i=1; i<=n; i++)
        {
            //printf("%d %d  %lld\n",b[i],a[i],(b[i]-a[i]+1)*high[i]);
            maxx=max(maxx,(b[i]-a[i]+1)*high[i]);
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值