HDU-1506-Largest Rectangle in a Histogram(区间DP)

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16869 Accepted Submission(s): 5000

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
这里写图片描述
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output
8
4000

很不错的DP
对于第i个数字,它左边连续最高的数字下标是Left[i]
对于第i个数字,它右边连续最高的数字下标是Right[i]
对于 6 2 5 2 5 5 2这组数据,结果应该是12
注意用long long

代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
using namespace std;
const long long int maxn=100005;
long long int num[maxn];
long long int Left[maxn];//num[i]左边连续最高点的下标为Left[i]
long long int Right[maxn];//num[i]右边连续最高点的下标为Left[i]
int main()
{
    long long int N;
    while(scanf("%I64d",&N)&&N)
    {
        for(long long int i=1; i<=N; i++)
            scanf("%I64d",&num[i]);
        Left[1]=1;
        for(long long int i=2;i<=N;i++)
        {
            long long int j=i;
            while(j>1&&num[j-1]>=num[i])//这一点很重要
                j=Left[j-1];
            Left[i]=j;
        }
        Right[N]=N;
        for(long long int i=N-1;i>=1;i--)
        {
            long long int j=i;
            while(j<N&&num[j+1]>=num[i])
                j=Right[j+1];
            Right[i]=j;
        }
        long long int result=0;
        for(long long int i=1;i<=N;i++)
        {
//            prlong long intf("%d %d\n",Left[i],Right[i]);
            if(result<(Right[i]-Left[i]+1)*num[i])
            {
                result=(Right[i]-Left[i]+1)*num[i];
            }
        }
        printf("%I64d\n",result);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值