I - Wormholes POJ - 3259

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

 

题目意思:就是判断的有没有负权回路;就是在一个农场里面从一个地方到另一个地方需要花费一定的时间,然后有单向的虫洞可以使时间倒流并且还能送到目的地

解题思路:就是套的bellman_Ford的模板,就是先用这个算法模板松弛一下图,然后在判断后面的点在进行松弛如果能松弛就是是有负权回路,不能继续松弛的话就是没有负权回路。。

代码如下:

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f;
using namespace std;
int main()
{
    int dis[11000],u[11000],v[11000],w[11000];
    int N;
    scanf("%d",&N);
    while(N--)
    {
        int n,m,s;
        scanf("%d%d%d",&n,&m,&s);
        int i,j,k;
        int a,b,c;
        for(i=0; i<2*m;)
            {
                scanf("%d%d%d",&a,&b,&c);
                u[i]=a;
                v[i]=b;
                w[i++]=c;
                u[i]=b;
                v[i]=a;
                w[i++]=c;
            }
        for(i=2*m; i<2*m+s; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            u[i]=a;
            v[i]=b;
            w[i]=-c;
        }
        for(i=0; i<=n; i++)
            dis[i]=inf;
        dis[1]=0;
        int flag=1;
        for(k=1; k<=n&&flag; k++)
        {
            flag=0;
            for(i=0; i<2*m+s; i++)
            {
                if(dis[v[i]]>dis[u[i]]+w[i])
                {
                    dis[v[i]]=dis[u[i]]+w[i];
                    flag=1;
                }
            }
        }
        int cher=0;
        for(i=0; i<2*m+s; i++)
        {
            if(dis[v[i]]>dis[u[i]]+w[i])
                cher=1;
        }
        if(cher==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值