poj-3259 Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

    题意是一个人要穿越到未来,但是之后还要回去,并且回去的时间要在他穿越之前。输入m组无向边,输入w组有向边。在构成最短路之后查找是否有负环,如果有则农民可以回来即YES,没有为NO。注意回来的有向边因为是时间倒流,花的时间是负值,这样才能构成负环。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#define INF 0x3f3f3f3f
#define mod 1000000007

using namespace std;


struct node
{
    int s,e,w;
}h[5100];
int dis[510];
int n;
void bellman(int k)
{
    int i,j;
    for (i=1;i<=n;i++)
        dis[i]=INF;
    dis[1]=0;
    for (i=1;i<n;i++)
    {
        int flag=0;
        for (j=0;j<k;j++)
        {
            if(dis[h[j].e]>dis[h[j].s]+h[j].w)
               {
                   dis[h[j].e]=dis[h[j].s]+h[j].w;
                   flag=1;
               }
        }
        if(!flag) break;
    }
    for (j=0;j<k;j++)
    {
        if(dis[h[j].e]>dis[h[j].s]+h[j].w)
        {
            printf("YES\n");
            break;
        }
    }
    if(j==k) printf("NO\n");
}
int main()
{
    int z,m,w;
    int s,e,t,i,j;
    scanf("%d",&z);
    while (z--)
    {
        int k=0,flag;
        scanf("%d%d%d",&n,&m,&w);
        for (i=0;i<m;i++)
        {
            scanf("%d%d%d",&s,&e,&t);
                h[k].s=s;
                h[k].e=e;
                h[k++].w=t;
                h[k].s=e;
                h[k].e=s;
                h[k++].w=t;
        }

        for (i=0;i<w;i++)
        {
            flag=0;
            scanf("%d%d%d",&s,&e,&t);
            h[k].s=s;
            h[k].e=e;
            h[k++].w=-t;
        }
        bellman(k);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值