航电2054 《A==B?》

A == B ?

*Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 160757 Accepted Submission(s): 26406
*

Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
Input
each test case contains two numbers A and B.
Output
for each case, if A is equal to B, you should print "YES", or print "NO".
Sample Input
1 2
2 2
3 3
4 3
Sample Output
NO
YES
YES
NO
//-std=c++11 -lwsock32
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#include<sstream>
#include<iterator>
using namespace std;
int main()
{
	std::ios::sync_with_stdio(false);
	
	string a,b;
	while(cin>>a>>b){
		//去除a前0 
		while(*a.begin() == '0') 
			a.erase(a.begin());
		//如果是小数 去掉后缀0 
		if(a.find(".") != a.npos)
		{
			while(*(a.end()-1) == '0') 
				a.erase(a.end()-1);
			if(*(a.end()-1) == '.')
				a.erase(a.end()-1);
		}
		//去除b前0 
		while(*b.begin() == '0') 
			b.erase(b.begin());
		//如果是小数 去掉后缀0 
		if(b.find(".") != b.npos)	
		{
			while(*(b.end()-1) == '0') 
				b.erase(b.end()-1);
			if(*(b.end()-1) == '.')
				b.erase(b.end()-1);
		}
			
		//去除负数的前导0
		if(*a.begin() == '-')
		{
			while(*(a.begin()+1) == '0') 
				a.erase(a.begin()+1);
		}
		if(*b.begin() == '-')
		{
			while(*(b.begin()+1) == '0') 
				b.erase(b.begin()+1); 
		}
		if(a=="-" || a=="") a="0";
		if(b=="-" || b=="") b="0";
//		cout<<"A="<<a<< "\t"<<"B="<<b<<endl;
		cout<<(a==b?"YES":"NO")<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值