POJ 2492 A Bug's Life(并查集)

A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 37618 Accepted: 12250

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

题目大意:
虫子a和b可以啪啪啪,问虫子里是否可以确定有同性恋。
并查集,在数组中加上是同性还是异性的信息就可以。没啥可说的。因为自己的合并又写错了所以给自己mark一下。

#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>
#include <cmath>
#include <cstring>
#define MAX 2200

struct node{
	int fa, rea;
}m_arr[MAX];

void fresh(int num){
	num += 10;
	int i;
	for(i = 0; i < num; i++){
		m_arr[i].fa = i;
		m_arr[i].rea = 0;
	}
	
}

int find(int num){
	int tmp = num, rea = 0;
	while(num != m_arr[num].fa){
		rea = rea xor m_arr[num].rea;
		num = m_arr[num].fa;
	}
	m_arr[tmp].fa = num;
	m_arr[tmp].rea = rea;
	return num;
}

void merge(int a, int b){
	int fa = find(a), fb = find(b);
	if(fa != fb){
		m_arr[fa].fa = fb;
		m_arr[fa].rea = 1 xor m_arr[a].rea xor m_arr[b].rea;
	}
}

bool solve(){
	int m, n, i, a, b, fa, fb;
	bool flag = true;
	scanf("%d%d", &m, &n);
	fresh(m);
	for(i = 0; i < n; i++){
		scanf("%d%d", &a, &b);
		if(flag){
			fa = find(a);
			fb = find(b);
			if(fa != fb) merge(a, b);
			else if(m_arr[a].rea xor m_arr[b].rea == 0) flag = false;
		}
	}
	return flag;
}

int main()
{
	int casen, k = 1;
	
	scanf("%d", &casen);
	while(casen--){
		if(solve()){
			printf("Scenario #%d:\n", k++);
			printf("No suspicious bugs found!\n");
		}
		else{
			printf("Scenario #%d:\n", k++);
			printf("Suspicious bugs found!\n");
		}
		if(casen)
			printf("\n");
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值