Description
Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.
There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:
1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).
In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.
Input
First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.
Output
Ouput results of the output operation in order, each line contains a number.
Sample Input
2 2 4 C 1 1 2 P 1 2 C 2 2 2 P 1 2
Sample Output
2 1
这道题可以用线段树维护区间的颜色种类,由于颜色种类少,所以可以状态压缩,下面是程序(注意有多组数据QAQ):
#include<stdio.h>
#include<iostream>
using namespace std;
const int N=100005;
struct treenode{
int lc,rc,w,c;
};
struct Segment_tree{
int k;
treenode t[N<<2];
void clear(){
k=1;
}
void pushdown(int rt){
if(t[rt].c){
t[t[rt].lc].w=t[t[rt].lc].c=t[t[rt].rc].w=t[t[rt].rc].c=t[rt].c;
t[rt].c=0;
}
}
void updata(int rt){
t[rt].w=t[t[rt].lc].w|t[t[rt].rc].w;
}
void build(int rt,int l,int r){
t[rt].c=0;
t[rt].w=2;
if(l==r){
t[rt].lc=t[rt].rc=0;
return;
}
int m=l+r>>1;
build(t[rt].lc=++k,l,m);
build(t[rt].rc=++k,m+1,r);
}
void change(int rt,int l,int r,int a,int b,int &w){
pushdown(rt);
if(l==a&&r==b){
t[rt].c=t[rt].w=1<<w;
return;
}
int m=l+r>>1;
if(b<=m){
change(t[rt].lc,l,m,a,b,w);
}
else{
if(a>m){
change(t[rt].rc,m+1,r,a,b,w);
}
else{
change(t[rt].lc,l,m,a,m,w);
change(t[rt].rc,m+1,r,m+1,b,w);
}
}
updata(rt);
}
int ask(int rt,int l,int r,int a,int b){
if(l==a&&r==b){
return t[rt].w;
}
pushdown(rt);
int m=l+r>>1;
if(b<=m){
return ask(t[rt].lc,l,m,a,b);
}
if(a>m){
return ask(t[rt].rc,m+1,r,a,b);
}
return ask(t[rt].lc,l,m,a,m)|ask(t[rt].rc,m+1,r,m+1,b);
}
}t;
int sum(int n){
int s=0;
while(n){
s+=n&1;
n>>=1;
}
return s;
}
int main(){
char c[10];
int n,m,l,r,w;
while(~scanf("%d%d%d",&n,&l,&m)){
t.clear();
t.build(1,1,n);
while(m--){
scanf("%s%d%d",&c,&l,&r);
if(l>r){
swap(l,r);
}
if(c[0]=='C'){
scanf("%d",&w);
t.change(1,1,n,l,r,w);
}
else{
printf("%d\n",sum(t.ask(1,1,n,l,r)));
}
}
}
return 0;
}