Catch That Cow——BFS

【题目描述】

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

    If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
    Input
    Line 1: Two space-separated integers: N and K
    Output
    Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
    Sample Input

    5 17

Sample Output

4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
【题目分析】
刚开始一直想用DFS做,还加上了记忆化,可是还是一直超时,对于这种求最少值 的问题,还是BFS比较有优势,因为队列本身自带最少属性(步数少加入的早,就总在前面),而且BFS没怎么优化就过了,说明数据还是比较友好的。
代码

#include<cstdio>
#include<queue>
#include<cstring>
#include<climits>

using namespace std;

int n,k,t,m,ans,p;
const int MAXN=100005;
int a[MAXN];

void BFS(int x)
{
	queue<int> q;
	q.push(x);
	a[x]=0;
	while(!q.empty())
	{
		t=q.front(); q.pop();
		if(t==k)
		{
			if(a[t]<ans)
			ans=a[t];
			return;
		}
		for(int i=0;i<3;i++)
		{
			if(i==0) m=t-1;
			else if(i==1) m=t+1;
			else if(i==2) m=t*2;
			if(m<0) continue;
			if(m>k)
			{
				p=a[t]+1+m-k;
				if(p<ans) ans=p;
				continue;
			}
			if(a[m]!=-1) continue;
			a[m]=a[t]+1;
			q.push(m);
		}
	}
}

int main()
{
	scanf("%d%d",&n,&k);
	memset(a,-1,sizeof(a));
	if(n>=k)
	{
		printf("%d",n-k);
	}
	else
	{
		ans=INT_MAX;
		BFS(n);
		printf("%d",ans);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值