Dertouzos (结论赛高)

A positive proper divisor is a positive divisor of a number  n n, excluding  n n itself. For example, 1, 2, and 3 are positive proper divisors of 6, but 6 itself is not. 

Peter has two positive integers  n n and  d d. He would like to know the number of integers below  n n whose maximum positive proper divisor is  d d.
Input
There are multiple test cases. The first line of input contains an integer  T T  (1T106) (1≤T≤106), indicating the number of test cases. For each test case: 

The first line contains two integers  n n and  d d  (2n,d109) (2≤n,d≤109).
Output
For each test case, output an integer denoting the answer. 
Sample Input
9
10 2
10 3
10 4
10 5
10 6
10 7
10 8
10 9
100 13
Sample Output
1
2
1
0
0
0
0
0

4

刚开始不知道结论,就直接暴力求解,当然超时了LOL

  1. 设p为d的最小质因子,a为2到p的所有质数,以d为最大非平凡(真)因子的数为a*d。 

证明:


ad=n ,d的最小的质因子为p, d=pp , p 最小为一

假设 a>p

n=app=p(ap)

a>p

ap>pp=d

a>pdn

dna<=p

dnan

至此结论得证

所以:

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<string.h>
#define LL long long
using namespace std;
bool isprime[100010];
int prime[100010],cnt;
void init(){
    memset(isprime,1,sizeof isprime);
    isprime[0]=isprime[1]=false;
    cnt=0;
    for(int i=2;i<=100000;++i){
        if(isprime[i]){
            prime[cnt++]=i;
            for(LL j=(LL)i*i;j<=100000;j+=i)
                isprime[j]=false;
        }
    }
}
int main(){
    int t;
    init();
    scanf("%d",&t);
    while(t--){
        int n,d;
        int ans=0;
        scanf("%d%d",&n,&d);
        n=(n-1)/d;
        for(int i=0;i<cnt&&prime[i]<=n;++i){
            ++ans;
            if(d%prime[i]==0)
                break;
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值