二分——hdu 4430 Yukari's Birthday

题目:

hdu 4430 Yukari’s Birthday
Today is Yukari’s n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it’s a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it’s optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.
Output
For each test case, output r and k.
Sample Input
18
111
1111
Sample Output
1 17
2 10
3 10

AC代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <cstdlib>
using namespace std;
long long  a[60];
long long  n, r, k;
long long power(long long x,long long i)
{
    long long x1 = 1;
    while (i--)
      {

          x1 *= x;
          if (x1 > n) return x1;
      }
    return x1;
}
bool check(long long  x)
{
    long long s =0, i;
    for (i = 1; i <= r; i++)
      {
          s += power (x,i);
          if(s > n) return false;

      }
    if(s == n) {
             if(a[r] !=0 && a[r] > x)
              a[r]=x;
              if (a[r] == 0)
              a[r]=x;
              }
    if(s == n - 1) {
             if(a[r] !=0 && a[r] > x)
             a[r]=x;
             if (a[r] == 0)
             a[r]=x;
    }
    return true;
}
int main()
{

    while (cin >> n)
    {
      memset(a,0,sizeof(a));
      a[1] = n-1;
      for (r =2; r <= 60; r++)
      {
         long long  st = 1, ed = pow(1e13,1.0/r)+1, mid;
          while (ed - st >1)
          {
              mid = st + (ed - st)/2;
              if (check(mid)) st = mid;
              else   ed = mid;
          }
      }
      long long m = 1e18,mr=0;
       for (r = 1; r <= 60; r++)
      {
          if (a[r]==0) continue;
          if (a[r]*r < m) {m = a[r]*r; mr = r;}
      }
      printf("%lld %lld\n",mr,a[mr]);
    }
    return 0;
}

题解 :

  1. 二分
  2. 防止溢出 ed = pow(1e13, 1.0/r)+1;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值