HDU 1241 Oil Deposits (裸DFS)

66 篇文章 0 订阅

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12076    Accepted Submission(s): 7005

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source
Mid-Central USA 1997

题目链接  :http://acm.hdu.edu.cn/showproblem.php?pid=1241

题目大意  :m * n的区域,@表示一个油槽,相连的@(包括八个方向)组成一个油田,求油田的个数

题目分析  :很经典的DFS,模版题

#include <cstdio>
int const MAX = 100 + 1;
//枚举八个方向
int p[8][2]={{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
char ch[MAX][MAX];
int m, n;
void dfs(int a,int b)       
{
    int x, y;
    for(int i = 0; i < 8; i++)
    {
        x = a + p[i][0];  
        y = b + p[i][1];
        //如果越界或者遇到*返回for循环
        if(x < 0 || x >= m || y < 0 || y >= n || ch[x][y] == '*')
          continue;
        ch[x][y] = '*';    //找到一个@将其赋值为*
        dfs(x,y);          //从当前点继续搜索    
    }    
}
int main()
{
  int count;
  while(scanf("%d%d",&m,&n) != EOF && (m+n))
  {
      for(int i = 0; i < m; i++)        //输入字符串
          scanf("%s",ch[i]);            
      count = 0;                        //初始化
      for(int i = 0; i < m; i++)
      {
          for(int j = 0; j < n; j++)
          {
              if(ch[i][j] == '@')       //若找到一个@,从它开始向周围遍历
              {
                dfs(i,j);
                count ++;     
              }          
          }
      }                    
      printf("%d\n",count);      
  }   
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值