POJ 2251 Dungeon Master (三维迷宫 BFS)

66 篇文章 0 订阅
Dungeon Master
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 16590Accepted: 6451

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
 
         Trapped!

 

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

Source

 

题目链接  :http://poj.org/problem?id=2251

 

题目大意  :三维迷宫求最短路

 

题目分析  :之前写了一篇二维迷宫,将其三维化即可,还是用BFS

 

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int const MAX = 31;
char map[MAX][MAX][MAX];
int vis[MAX][MAX][MAX];
int x, y, z;
int dirx[6] = {0,0,0,0,1,-1};
int diry[6] = {0,0,1,-1,0,0};
int dirz[6] = {1,-1,0,0,0,0};
int sx, sy, sz;
int ex, ey, ez;
struct Point
{
    int x, y, z;
    int step;
};

int BFS()
{
    memset(vis,0,sizeof(vis));
    queue<Point> q;
    Point node, t;
    node.x = sx;
    node.y = sy;
    node.z = sz;
    node.step = 0;
    q.push(node);
    vis[sx][sy][sz] = 1;
    while(!q.empty())
    {
        node = q.front();
        q.pop();
        for(int i = 0; i < 6; i++)  //6个方向
        {
            t = node;
            t.x += dirx[i];
            t.y += diry[i];
            t.z += dirz[i];
            t.step++;
            if(t.x == ex && t.y == ey && t.z == ez)
                return t.step;
            if(t.x < 1 || t.x > x || t.y < 1 || t.y > y || t.z < 1 || t.z > z || !map[t.x][t.y][t.z] || vis[t.x][t.y][t.z])
                continue;
            else
            {
                vis[t.x][t.y][t.z] = 1;
                q.push(t);
            }
        }
    }
    return -1;
}

int main()
{
    char str[31];
    while(scanf("%d %d %d", &x, &y, &z) != EOF && (x+y+z))
    {
        memset(map,1,sizeof(map));
        for(int i = 1; i <= x; i++)
        {
            for(int j = 1; j <= y; j++)
            {
                scanf("%s",str + 1);   //这里要注意,输入的字符下标从1开始
                for(int k = 1; k <= z; k++)
                {
                    if(str[k] == 'S')
                    {
                        sx = i;
                        sy = j;
                        sz = k;
                    }
                    if(str[k] == 'E')
                    {
                        ex = i;
                        ey = j;
                        ez = k;
                    }
                    if(str[k] == '#')
                        map[i][j][k] = 0;
                }
            }
        }
        if(BFS() == -1)
            printf("Trapped!\n");
        else
            printf("Escaped in %d minute(s).\n", BFS());
    }
}


 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值