NOJ 1098 Rails (stack)

Rails

Time Limit(Common/Java):1000MS/3000MS          Memory Limit:65536KByte
Total Submit:384            Accepted:117

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has coaches numbered in increasing order . The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be . Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of The last line of the block contains just 0.
The last block consists of just one line containing 0.

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

Source

Central European Regional 1997


题目链接 :http://acm.njupt.edu.cn/acmhome/problemdetail.do?&method=showdetail&id=1098


题目大意 :给一串顺序数字序列,通过栈操作判断能否得到目标序列


题目分析 :简单的栈操作,手动数组模拟栈或者用stack均可



#include <cstdio>
#include <cstring>
int const MAX = 1000 + 10;
int target[MAX];
int main()
{
    int n;
    while(scanf("%d", &n) != EOF && n)
    {
        bool flag = false, ok;
        memset(target, 0, sizeof(target));
        while(!flag)
        {
            ok = true;
            for(int i = 1; i <= n; i++)
            {
                scanf("%d", &target[i]);
                if(target[1] == 0)
                {
                    flag = true;
                    break;
                }
            }
            if(flag)
                continue;
            int stack[MAX], top = 0;
            int in = 1, out = 1;
            while(out <= n)
            {
                //若第一个元素等于出栈序列的第一个元素,则进栈后直接出栈
                if(in == target[out])
                {
                    in ++;
                    out ++;
                }
                //若栈内存在元素并且栈顶元素等于当前出栈序列所对应的元素
                //则将其出栈,出栈序列的指针后移
                else if(top && stack[top] == target[out])
                {
                    top --;
                    out ++;
                }
                //若元素未进栈,则将其进栈
                else if(in <= n)
                    stack[++ top] = in ++;
                //上面三个都不满足,及元素都已进栈,但不满足出栈规则
                //说明当前出栈序列不合法,ok置0,退出循环
                else
                {
                    ok = false;
                    break;
                }
            }
            printf("%s\n", ok ? "Yes" : "No");
        }
        printf("\n");
    }
}

另外附上字符串序列的代码

/*
输入:
5
A, B, C, D, E
5
A, C, E, B, D
5
C, A, B, D, E
5
E, D, C, B, A
0
输出:
Yes
No
No
Yes
*/
#include <cstdio>
#include <cstring>
int const MAX = 1e3 + 5;
char str[MAX];
char target[MAX];
int main()
{
	int n;
	while(scanf("%d", &n) != EOF && n)
	{
		getchar(); //吸取换行符
		int stack[MAX], top = 0; //模拟栈
		int in = 1, out = 1; 
		gets(str);  //输入字符串
		int len = strlen(str);
		int cnt = 1;
		for(int i = 0; i < len; i++)  //得到目标串
			if(str[i] >= 'A' && str[i] <= 'Z')
				target[cnt++] = str[i];
		int ok = 1;  //判断是否可行
		while(out <= n)  //当出栈数小于总数时
		{
			//若第一个元素等于出栈序列的第一个元素,则进栈后直接出栈
			if(in == target[out] - 'A' + 1)
			{
				in ++;
				out ++;
			}
			//若栈内存在元素并且栈顶元素等于当前出栈序列所对应的元素
			//则将其出栈,出栈序列的指针后移
			else if(top && stack[top] == target[out] - 'A' + 1)
			{
				top --;
				out ++;
			}
			//若元素未进栈,则将其进栈
			else if(in <= n)
				stack[++top] = in ++;
			//上面三个都不满足,及元素都已进栈,但不满足出栈规则
			//说明当前出栈序列不合法,ok置0,退出循环
			else 
			{
				ok = 0;
				break;
			}
		}
		printf("%s\n", ok ? "Yes" : "No");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值