Best Reward (manacher--o(n))

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value.
 

Input

The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000.
 

Output

Output a single Integer: the maximum value General Li can get from the necklace.

Sample Input

2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac

Sample Output

1
6

题意:对于每组测试,第一行给出a到z这26个小写字母的价值,然后接下来给出一个字符串,要求将这个字符串分为两部分,并分别计算他们的价值然后加起来作为总价值,计算规则为:若是回文串则把每个字符的价值加起来作为当前串的价值,否则当前串的价值为0,求所有分割方案中总价值最大的方案的总价值。 

思路:首先用sum数组记录一下当前串的前缀的价值,即:求一个前缀和,为了在算其某一个[l,r]子串的价值时,只需要用sum[r]-sum[l-1]即可o(1)次地算出,然后跑一遍o(n)的manacher,同时用l[i]和r[i]数组分别记录i的左边长度为i的前缀和i右边长度为len-i的后缀是否为回文串(len为s在跑manacher之前的初始长度),然后遍历一遍1~len-1,枚举所有分割点,用l和r数组判断是否为回文,再做相应的计算即可,所以总的时间复杂度为o(n)。

完整代码:

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>

using namespace std;

const int maxn=1e6+5;

int p[maxn],v[maxn],sum[maxn];
bool l[maxn],r[maxn];
string s;

void init(string &s)
{
	string m="$#";
	for(int i=0;i<s.size();i++){
		m+=s[i];
		m+='#';
	}
	s=m;
	memset(p,0,sizeof p);
}

void manacher(string &s)
{
	init(s);
	int id=0,mx=0;
	for(int i=1;i<=s.size();i++){
		if(i<mx) p[i]=min(p[2*id-i],mx-i);
		else p[i]=1;
		while(s[i-p[i]]==s[i+p[i]]) p[i]++;
		if(i+p[i]>mx){
			mx=i+p[i];
			id=i;
		}
		if(p[i]==i) l[p[i]-1]=true;
		if(p[i]+i==s.size()) r[p[i]-1]=true;
	}
}

int main()
{
	int t;
	cin>>t;
	while(t--){
		memset(v,0,sizeof v);
		memset(l,false,sizeof l);
		memset(r,false,sizeof r);
		memset(sum,0,sizeof sum);
		for(int i=0;i<26;i++) cin>>v[i];
		cin>>s;
		int len=s.size();//注意:这里要把跑manacher之前的s的长度取出来,否则跑完manacher,s的长度就变了
		for(int i=1;i<=len;i++) sum[i]=sum[i-1]+v[s[i-1]-'a'];
		manacher(s);
		int ans=0;
		for(int i=1;i<len;i++){
			int res=0;
			if(l[i]) res+=sum[i];
			if(r[len-i]) res+=sum[len]-sum[i];
			//cout<<l[i]<<" "<<r[len-i]<<endl;
			ans=max(ans,res);
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值