POJ 3070 Fibonacci (矩阵快速幂 Fibonacci数列新求法)

78 篇文章 0 订阅


Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9974 Accepted: 7115

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

Stanford Local 2006


题目链接:http://poj.org/problem?id=3070

题目大意:求Fibonacci数列的后四位

题目分析:矩阵已经给了,直接矩阵快速幂对10000取余

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MOD = 1e4;
struct matrix
{
    int m[5][5];
}a;

matrix multiply(matrix x, matrix y)
{
    matrix ans;
    memset(ans.m, 0, sizeof(ans.m));
    for(int i = 1; i <= 2; i++)
        for(int j = 1; j <= 2; j++)
            if(x.m[i][j])
                for(int k = 1; k <= 2; k++)
                    ans.m[i][k] = (ans.m[i][k] + x.m[i][j] * y.m[j][k]) % MOD;
    return ans;
}

matrix quickmod(matrix a, int p)
{
    matrix ans;
    memset(ans.m, 0, sizeof(ans.m));
    for(int i = 1; i <= 2; i++)
        ans.m[i][i] = 1;
    while(p)
    {
        if(p & 1)
            ans = multiply(ans, a);
        p >>= 1;
        a = multiply(a, a);
    }
    return ans;
}

int main()
{   
    int n;
    matrix a;
    a.m[1][1] = 1; 
    a.m[1][2] = 1;
    a.m[2][1] = 1;
    a.m[2][2] = 0;
    while(scanf("%d", &n) != EOF && n != -1)
    {
        if(n == 0)
        {
            printf("0\n");
            continue;
        }
        matrix ans = quickmod(a, n - 1);
        printf("%d\n", ans.m[1][1]);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值