poj3070矩阵快速幂求斐波那契数列

 

 
Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13172 Accepted: 9368

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875


思路:没得说,矩阵快速幂

代码如下:

 

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mod = 10000;
const int N = 2;//矩阵的维数,角标从0开始
struct Matrix
{
    __int64 v[N][N];
    Matrix()
    {
        memset(v,0,sizeof(v));
    }
};
//矩阵的乘法p1*p2
Matrix multi(Matrix p1,Matrix p2)
{
    Matrix res;
    for(int i=0;i<N;i++)
        for(int j=0;j<N;j++)
            if(p1.v[i][j])//代码优化,是0的话就不用计算
                for(int k=0;k<N;k++)
                    res.v[i][k]=(res.v[i][k]+(p1.v[i][j]*p2.v[j][k]))%mod;
    return res;
}
//矩阵的快速幂p^k
Matrix pow(Matrix p,__int64 k)
{
    Matrix t;
    for(int i=0;i<N;i++)//初始化为单位矩阵
        t.v[i][i]=1;
    while(k)
    {
        if(k&1)
            t=multi(t,p);
        p=multi(p,p);
        k=k>>1;
    }
    return t;
}


int main()
{
    __int64 n;
    Matrix e,ans;
    e.v[0][0]=e.v[0][1]=e.v[1][0]=1;
    e.v[1][1]=0;
    while(scanf("%I64dd",&n)!=EOF&&n!=-1)
    {
        ans = pow(e,n);
        printf("%I64d\n",ans.v[0][1]);
    }
    return 0;
}

 

 

 

 

转载于:https://www.cnblogs.com/wt20/p/5782960.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值