HDU 5135 Little Zu Chongzhi's Triangles (14广州 状压dp)


Little Zu Chongzhi's Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 474    Accepted Submission(s): 252

Problem Description

Zu Chongzhi (429–500) was a prominent Chinese mathematician and astronomer during the Liu Song and Southern Qi Dynasties. Zu calculated the value ofπ to the precision of six decimal places and for a thousand years thereafter no subsequent mathematician computed a value this precise. Zu calculated one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also worked on deducing the formula for the volume of a sphere.

It is said in some legend story books that when Zu was a little boy, he liked mathematical games. One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using them. He wanted to make some triangles by those sticks, and he wanted the total area of all triangles he made to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.
2) A triangle's vertexes must be end points of sticks. A triangle's vertex couldn't be in the middle of a stick.
3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problem rather than a mathematical problem. You can't solve that problem without a computer if there are too many sticks. So please bring your computer and go back to Zu's time to help him so that maybe you can change the history.
 

Input
There are no more than 10 test cases. For each case:

The first line is an integer N(3 <= N<= 12), indicating the number of sticks Zu Chongzhi had got. The second line contains N integers, meaning the length of N sticks. The length of a stick is no more than 100. The input ends with N = 0.
 

Output
For each test case, output the maximum total area of triangles Zu could make. Round the result to 2 digits after decimal point. If Zu couldn't make any triangle, print 0.00 .
 

Sample Input
  
  
3 1 1 20 7 3 4 5 3 4 5 90 0
 

Sample Output
  
  
0.00 13.64
 

Source
2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5135

题目大意:给n个木条拼任意多个三角形,不一定全部用完,问用它们能拼成的最大面积和

题目分析:状压dp,贪心也能过,这里不考虑,记录下所有合法的状态,即满足三角形条件的(1 << i) | (1 << j) | (1 << k),并用海伦公式计算出对应的面积,枚举在各个状态下的值,最后取最大值

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const MAX = (1 << 13);
int ok[MAX], a[105];
double re[MAX], dp[MAX];

bool judge(int a, int b, int c)
{
    if(a + b > c && a + c > b && b + c > a)
        return true;
    return false;
}

double area(int a, int b, int c)
{
    double p = (a + b + c) / 2.0;
    return sqrt(p * (p - a) * (p - b) * (p - c));
}

int main()
{
    int n;
    while(scanf("%d", &n) != EOF && n)
    {
        int cnt = 0;
        bool flag = false;
        memset(dp, 0, sizeof(dp));
        memset(re, 0, sizeof(re));
        for(int i = 0; i < n; i++)
            scanf("%d", &a[i]);
        sort(a, a + n);
        for(int i = 0; i < n; i++)
            for(int j = i + 1; j < n; j++)
                for(int k = j + 1; k < n; k++)
                    if(judge(a[i], a[j], a[k]))
                    {
                        flag = true;
                        ok[cnt] = ((1 << i) | (1 << j) | (1 << k));
                        re[cnt++] = area(a[i], a[j], a[k]);
                    }
        if(!flag)
        {
            printf("0.00\n");
            continue;
        }
        for(int i = 0; i <= MAX; i++)
            for(int j = 0; j < cnt; j++)
                if(!(i & ok[j]))
                    dp[(i | ok[j])] =  dp[i] + re[j];
        double ans = 0.0;
        for(int i = 0; i <= MAX; i++)
            ans = max(ans, dp[i]);
        printf("%.2f\n", ans);
    }
}



 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值