POJ 3295 Tautology (栈模拟)

129 篇文章 0 订阅
37 篇文章 0 订阅

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10096 Accepted: 3847

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source

Waterloo Local Contest, 2006.9.30

题目链接:http://poj.org/problem?id=3295

题目大意:按题意计算所给表达式的值,相当于一个带栈功能的位运算器

题目分析:暴力枚举所有p,q,r,s,t的可能值,用栈模拟算出结果,若为0则not否则是tautology


#include <cstdio>
#include <stack>
#include <cstring>
using namespace std;
int const MAX = 150;

stack <int> st;
char s[MAX];

void cal(int p, int q, int r, int s1, int t)
{
    int len = strlen(s);
    for(int i = len - 1; i >= 0; i --)
    {
        if(s[i] == 'p')
            st.push(p);
        else if(s[i] == 'q')
            st.push(q);
        else if(s[i] == 'r')
            st.push(r);
        else if(s[i] == 's')
            st.push(s1);
        else if(s[i] == 't')
            st.push(t);
        else if(s[i] == 'K')
        {
            int t1 = st.top();
            st.pop();
            int t2 = st.top();
            st.pop();
            st.push(t1 && t2);
        }
        else if(s[i] == 'A')
        {
            int t1 = st.top();
            st.pop();
            int t2 = st.top();
            st.pop();
            st.push(t1 || t2);
        }
        else if(s[i] == 'N')
        {
            int t1 = st.top();
            st.pop();
            st.push(!t1);
        }
        else if(s[i] == 'C')
        {
            int t1 = st.top();
            st.pop();
            int t2 = st.top();
            st.pop();
            if(t1 == 1 && t2 == 0)
                st.push(0);
            else 
                st.push(1);
        }
        else if(s[i] == 'E')
        {
            int t1 = st.top();
            st.pop();
            int t2 = st.top();
            st.pop();
            if((t1 == 1 && t2 == 1) || (t1 == 0 && t2 == 0))
                st.push(1);
            else
                st.push(0);
        }
    }
}

bool judge()
{
    for(int p = 0; p < 2; p++)
        for(int q = 0; q < 2; q++)
            for(int r = 0; r < 2; r++)
                 for(int s1 = 0; s1 < 2; s1++)
                    for(int t = 0; t < 2; t++)
                     {
                        cal(p, q, r, s1, t);
                        if(st.top() == 0)
                            return false;
                    }
    return true;
}

int main()
{
    while(scanf("%s", s) != EOF && !(strlen(s) == 1 && s[0] == '0'))   
    {
        if(judge())
            printf("tautology\n");
        else
            printf("not\n");
    } 
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值