poj 3295 Tautology (模拟栈操作+状压)

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input
ApNp
ApNq
0
Sample Output
tautology
not


判断一个表达式是否是重言式,所以用状压枚举所有情况,从后往前遍历字符串,用栈模拟

N !   A ||    K &&    C (!x)||y     E== 


#include <algorithm>
#include <string.h>
#include <iostream>
#include <stdio.h>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <stack>
using namespace std;
typedef long long LL;
const int N = 2010;
int v[10];
char str[100];
stack<int>q;

int main()
{
    while(scanf("%s",str),str[0]!='0')
    {
        int flag=1;
        for(int i=0;i<(1<<5);i++)
        {
            memset(v,0,sizeof(v));
            for(int j=0;j<5;j++)
            {
                if(i&(1<<j)) v[j]=1;
            }
            int len=strlen(str);
            while(!q.empty()) q.pop();
            for(int j=len-1;j>=0;j--)
            {
                if(str[j]>='p'&&str[j]<='t') q.push((v[str[j]-'p']));
                else
                {
                    if(str[j]=='N')
                    {
                        int tmp=q.top();q.pop();
                        q.push(!tmp);
                        continue;
                    }
                    else if(str[j]=='A')
                    {
                        int tmp1=q.top();q.pop();
                        int tmp2=q.top();q.pop();
                        q.push(tmp1||tmp2);
                        continue;
                    }
                    else if(str[j]=='K')
                    {
                        int tmp1=q.top();q.pop();
                        int tmp2=q.top();q.pop();
                        q.push(tmp1&&tmp2);
                        continue;
                    }
                    else if(str[j]=='E')
                    {
                        int tmp1=q.top();q.pop();
                        int tmp2=q.top();q.pop();
                        q.push(tmp1==tmp2);
                        continue;
                    }
                    else
                    {
                        int tmp1=q.top();q.pop();
                        int tmp2=q.top();q.pop();
                        q.push((!tmp1)||tmp2);
                        continue;
                    }
                }
            }
            if(q.top()==0)
            {
                flag=0;
                break;
            }
        }
        if(flag) puts("tautology");
        else puts("not");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值