POJ 2773 Happy 2006 (分解质因数+容斥+二分 或 欧几里德算法应用)

78 篇文章 0 订阅
56 篇文章 0 订阅


Happy 2006
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 10309 Accepted: 3566

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source

POJ Monthly--2006.03.26,static

题目链接:http://poj.org/problem?id=2773

题目大意:求第k个与m互质的数

题目分析:两种方法,主流方法是分解质因数+二分+容斥,0ms过,先对m分解质因数,然后二分,二分时用容斥计算1到当前数字与m不互质的数的个数,然后用m减,就是与m互质的数的个数。

#include <cstdio>
#include <cstring>
#define ll long long
int const MAX = 1e6 + 6;
int fac[MAX];
int n, k, cnt;
ll sum;

void get_Factor(int x)
{
    cnt = 0;
    for(int i = 2; i <= x; i++)
    {
        if(x % i == 0)
            fac[cnt ++] = i;
        while(x % i == 0)
            x /= i;
    }
    if(x > 1)
        fac[cnt ++] = x;
}

void DFS(int pos, int num, ll cur, ll x)
{
    if(pos == cnt)
    {
        if(cur == 1)
            return;
        if(num & 1)
            sum += x / cur;
        else
            sum -= x / cur;
        return;
    }
    DFS(pos + 1, num, cur, x);
    DFS(pos + 1, num + 1, cur * fac[pos], x);
    return;
}

ll cal(ll mid)
{
    sum = 0;
    DFS(0, 0, 1, mid);
    return sum;
}

int main()
{
    while(scanf("%d %d", &n, &k) != EOF)
    {
        get_Factor(n);
        ll l = 0, r = 1e17, mid;
        while(l <= r)
        {
            mid = (l + r) >> 1;
            if(mid - cal(mid) < k)
                l = mid + 1;
            else 
                r = mid - 1;
        }
        printf("%lld\n", l);
    }
}


第二种方法利用了欧几里德算法,gcd(a, b) = gcd(b, a % b),令a = km + i,b = m则有:
gcd(km + i, m) = gcd(i, m),说明与m互质的数对m取模有周期性,因此设小于m且与m互质的数有cnt个,第i个为ai,则第m*cnt+i个为m*cnt+ai,其次要注意k整除cnt的时候,取到的实际上是a[cnt]而不是a[0],这个方法跑了2400ms+

#include <cstdio>
int const MAX = 1e6 + 5;
int a[MAX];

int gcd(int a, int b)
{
    while(b)
    {
        int tmp = a;
        a = b;
        b = tmp % b;
    }
    return a;
}

int main()
{
    int m, k;
    while(scanf("%d %d", &m, &k) != EOF)
    {
        if(k == 1)
        {
            printf("1\n");
            continue;
        }
        if(m == 1)
        {
            printf("%d\n", k);
            continue;
        }
        int cnt = 1;
        for(int i = 1; i <= m; i++)
            if(gcd(i, m) == 1)
                a[cnt ++] = i;
        cnt --; 
        if(k % cnt == 0)
            printf("%d\n", (k / cnt - 1) * m + a[cnt]);
        else
            printf("%d\n", (k / cnt) * m + a[k % cnt]);
    }
}



 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值