PAT 1057 Stack (30) (树状数组+二分 典型题)

1057. Stack (30)

时间限制:150 ms
内存限制:65536 kB

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目链接:https://www.patest.cn/contests/pat-a-practise/1057

题目大意:实现一个支持求中位数的栈

题目分析:普通模拟复杂度肯定炸,考虑使用树状数组加二分的方法,先算出当前中位数是栈中第几大设为k,然后二分答案,用树状数组维护升序排列下第i个数字到第1个数字间的数字个数,判断即可,这里要注意的是答案需要取上界,而且并不是二分值算出的结果恰好等于k时取答案而是大于等于k,举个简单的例子:1 1 2 2 3 3,这个数列的中位数显然是第3大的2,但其实第3大和第4大都是2。1,2,3对应得sum值为2,4,6,并没有6/2=3这个值,因为两个2是一样大的,所以二分时要取上界作为答案。

#include <cstdio>
#include <cstring>
int const MAX = 1e5 + 5;
int const CON = 1e5;
int stk[MAX], a[MAX], top;
char s[20];

int lowbit(int x)
{
    return x & (-x);
}

void add(int x, int val)
{
    for(int i = x; i <= CON; i += lowbit(i))
        a[i] += val;
}

int sum(int x)
{
    int ans = 0;
    for(int i = x; i > 0; i -= lowbit(i))
        ans += a[i];
    return ans;
}

int get_mid(int x)
{
    int l = 1, r = 1e5, mid, ans;
    while(l <= r)
    {
        mid = (l + r) >> 1;
        int num = sum(mid);
        if(num >= x)
        {
            ans = mid;
            r = mid - 1;
        }
        else
            l = mid + 1;
    }
    return ans;
}

int main()
{
    int n, x;
    scanf("%d", &n);
    top = 0;
    while(n --)
    {
        scanf("%s", s);
        if(s[1] == 'o')
        {
            if(top == 0)
                printf("Invalid\n");
            else
            {
                x = stk[top --];
                add(x, -1);
                printf("%d\n", x);
            }
        }
        else if(s[1] == 'u')
        {
            scanf("%d", &x);
            stk[++ top] = x;
            add(x, 1);
        }
        else
        {
            if(top == 0)
                printf("Invalid\n");
            else
                printf("%d\n", get_mid((top + 1) >> 1));
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值