FZU 2214 Knapsack problem (0/1背包)

Knapsack problem

Time Limit: 3000 mSec    Memory Limit : 32768 KB

Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

1
5 15
12 4
2 2
1 1
4 10
1 2

Sample Output

15

Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

题目分析:http://acm.fzu.edu.cn/problem.php?pid=2214

题目大意:n个物品,背包限重B,每个物品价值vi,重量wi,求最大价值

题目分析:由于B很大而v的总和很小,定义dp[i]为价值为i时的最小重量做0/1背包

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const INF = 0x3fffffff;
int dp[5005], w[505], v[505];

int main() {
	int T;
	scanf("%d", &T);
	while(T --) {
		int n, B, sum = 0;
		scanf("%d %d", &n, &B);
		for(int i = 0; i < n; i++) {
			scanf("%d %d", &w[i], &v[i]);
			sum += v[i];
		}
		for(int i = 0; i < 5005; i++) {
			dp[i] = INF;
		}
		dp[0] = 0;
		for(int i = 0; i < n; i++) {
			for(int j = sum; j >= v[i]; j--) {
				dp[j] = min(dp[j], dp[j - v[i]] + w[i]);
			}
		}
		int ans = 0;
		for(int i = sum; i >= 0; i--) {
			if(dp[i] <= B) {
				ans = i;
				break;
			}
		}
		printf("%d\n", ans);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值