POJ 1113 && HDU 1348 Wall (凸包周长 graham扫描法)

77 篇文章 8 订阅
22 篇文章 0 订阅

Wall

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5867    Accepted Submission(s): 1671


Problem Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.



The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.
 
Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.
Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
 
Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
 
Sample Input
  
  
1 9 100 200 400 300 400 300 300 400 300 400 400 500 400 500 200 350 200 200 200
 
Sample Output
  
  
1628

Source
 
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1348

题目大意:要在城堡周围建城墙,要求城墙离城堡的距离不得小于L,城堡是个多边形,给出城堡端点坐标,求最小的城墙边长。

题目分析:由于要求城墙的边长最小,所以对于凹的区域,城墙必不能凹进去,三角形两边之和大于第三边, 对于端点处的城墙应取圆弧而不是直角,显然圆弧要更短些,由于内角和为360,所以所有圆弧组合起来正好是一个边长为L的整圆,求凸包用graham扫描法,时间复杂度O(nlogn),这篇博客讲解的比较好计算几何之凸包----Graham扫描法
简单说下向量叉积的用法,坐标原点为O(0, 0),对于两个点P1(x1, y1), P2(x2, y2),P1 X P2 = x1y2 - y1x2,若大于0根据右手定则可知OP1在OP2的顺时针方向,等于0共线,小于0则OP1在OP2的逆时针方向。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int const MAX = 1005;
double const PI = 4.0 * atan(1.0);
int n;
double l;

struct POINT {
    double x, y;
}p[MAX], stk[MAX], base;
int top;

double getDist(POINT a, POINT b) {
    return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}

//大于0 => p0p1在p1p2的顺时针
int getCross(POINT p0, POINT p1, POINT p2) {
    //POINT p0_1(p1.x - p0.x, p1.y - p0.y);
    //POINT p0_2(p2.x - p0.x, p2.y - p0.y);
    return (p1.x - p0.x) * (p2.y - p0.y) - (p1.y - p0.y) * (p2.x - p0.x);
}

bool cmp (POINT a, POINT b) {
    int crossAns = getCross(base, a, b);
    if (crossAns == 0) {
        return getDist(a, base) < getDist(b, base);
    }
    if (crossAns > 0) {
        return true;
    }
    return false;
}

void getBase() {
    scanf("%lf %lf", &p[0].x, &p[0].y);
    base.x = p[0].x;
    base.y = p[0].y;
    int pos = 0;
    for (int i = 1; i < n; i ++) {
        scanf("%lf %lf", &p[i].x, &p[i].y);
        if (p[i].y < base.y || (p[i].y == base.y && p[i].x < base.x)) {
            pos = i;
            base.x = p[i].x;
            base.y = p[i].y;
        }
    }
    swap(p[0], p[pos]);
}

int main() {
    int T;
    scanf("%d", &T);
    for (int ca = 0; ca < T; ca ++) {
        scanf("%d %lf", &n, &l);
        getBase();
        sort(p + 1, p + n, cmp);
        stk[0] = p[0];
        stk[1] = p[1];
        top = 1;
        for (int i = 2; i < n; i ++) {
            while (top > 0 && getCross(stk[top - 1], stk[top], p[i]) <= 0) {
                top --;
            }
            stk[++ top] = p[i];
        }
        double ans = 0;
        for (int i = 0; i < top; i ++) {
            ans += getDist(stk[i], stk[i + 1]);
        }
        ans += getDist(stk[top], stk[0]);
        ans += 2.0 * PI * l;
        printf("%.0f\n", ans); 
        if (ca != T - 1) {
            printf("\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值