电话聊天狂人  c++ stl

 

 

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤10​5​​),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3

 

#include<bits/stdc++.h>
using namespace std;

typedef pair<string, double> PAIR;

struct CmpByValue
{
    bool operator()(const PAIR& a, const PAIR& b)
    {
        return a.second > b.second;
    }
};

int main()
{
    map<string, int> ma;
    int n;
    cin>>n;
    string str;
    ma.clear();
    for(int i=0; i<2*n; ++i)
    {
        cin>>str;
        ma[str]+=1;
    }
    vector<PAIR> ma_vec(ma.begin(), ma.end());
    sort(ma_vec.begin(), ma_vec.end(), CmpByValue());
    set<string> se;
    se.insert(ma_vec[0].first);
    for(int i=1; i<2*n; ++i)
    {
        if(ma_vec[i].second==ma_vec[i-1].second)
            se.insert(ma_vec[i].first);
        else
            break;
    }
    set<string>::iterator it;
    it=se.begin();
    if(se.size()==1)
    {
        cout<<*it<<" "<<ma_vec[0].second<<endl;
    }
    else
        cout<<*it<<" "<<ma_vec[0].second<<" "<<se.size()<<endl;

}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值