poj 1017 Packets装箱子

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33802 Accepted: 11180

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

 

一个工厂制造的产品形状都是长方体,它们的高度都是h,长和宽都相等,一共有六个
型号,他们的长宽分别为1*1, 2*2, 3*3, 4*4, 5*5, 6*6. 这些产品通常使用一个 6*6*h 的长方
体包裹包装然后邮寄给客户。因为邮费很贵,所以工厂要想方设法的减小每个订单运送时的
包裹数量。他们很需要有一个好的程序帮他们解决这个问题从而节省费用。现在这个程序由
你来设计。

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 
#include <stdio.h>
int main(int argc, char *argv[])
{
	int a,b,c,d,e,f,x,y;
	int sum;
	int u[4]={0,5,3,1};//型号3*3的剩余数量的多少和箱中剩余2*2空间的关系 
	while(scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f))
    {
    	sum=0;
    	if(a==0 && b==0 && c==0 && d==0 && e==0 && f==0)
    	break;
    	sum=f+e+d+(c+3)/4;
    	x=5*d+u[c%4];//2*2剩余的空间 
    	if(b>x) sum=sum+(b-x+8)/9;
    	y=36*sum-36*f-25*e-16*d-9*c-4*b;//1*1的剩余空间(总面积减去除1*1外的箱子面子) 
		if(a>y) sum=sum+(a-y+35)/36;
		printf("%d\n",sum); 
    }
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值