hdu 1671(字典树)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21822    Accepted Submission(s): 7402


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
NO
YES
 
 
 
题意:
给你一堆电话号码 问你是不是存在任意一个号码这个号码是另外一个号码的开头(就是包含关系 你懂吧 大概就这样)
先保存了所有的电话号码 然后Insert所有的号码 在从头便利一边  每次询问当前号码是不是其他任意号码的前缀  第一次wa了 是因为有可能先输入的号码的前缀是后输入的号码
所以必须等所有的号码都在字典树中之后在询问 大概就这样

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 100105;
int tree[N][10];
bool nums[N];
int cnt;
void Insert(char *p)
{
	int i = 0, k = 0;
	int length_p = strlen(p);
	bool flag = false;
	while (p[i]) {
		int pos = p[i++]- '0';
		if(tree[k][pos] == 0) {	
			tree[k][pos] = cnt++;
		}
		k = tree[k][pos];
		nums[k] = true;
	}
}
bool Find(char *str)
{
	int i = 0, k = 0;
	while (str[i]) {
		int pos = str[i++] - '0';
		if (!tree[k][pos])
			return false;
		k = tree[k][pos];
	}
	for (int i = 0; i < 10; i ++) {
		if (tree[k][i])
			return true;
	}
	return false;
}
int main()
{
	int _;
	char str[10002][11];
	scanf("%d",&_);
	while (_ --) {
		cnt = 1;
		memset(nums , false, sizeof(nums));
		memset(tree , 0, sizeof(tree));
		int n;
		scanf("%d",&n);
		int ok = false;
		for (int i = 0; i < n; i ++) {
			scanf("%s",str[i]);
			Insert(str[i]);
		}
		for (int i = 0; i < n; i ++) {
			if (Find(str[i])) {
				ok = true;break;
			}
		}
		if (ok) printf("NO\n");
		else printf("YES\n");
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值