HDU 1671 字典树水题 Phone List

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2 3 911 97625999 91125426 5 113 12340 123440 12345 98346

Sample Output

NO YES

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1671

 

题目大意:  看一堆电话号码中是不是某个电话号码是其中一个电话号码的前缀 如果有 则不能打通 输出NO 没有就全部能连通 输出YES

添加两个标价, 一个是flag2,用来表示是否有一个串在该节点结束,这主要是针对前面的串中出现过当前串的前缀;

另一个是flag1,用来标志当前当一个串结束时,它是否存在下一个节点,主要针对当前串是之前出现过的串的前缀

 

需要注意的是, 这道题必须释放内存, 否则会MLE ....

 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 20 ;

struct Node{
    Node *next[10] ;
    int flag1, flag2 ;
    Node(){
        for (int i = 0; i < 10; i++){
            next[i] = NULL;
        }
        flag1 = 0, flag2 =0;
    }
};

Node *root ;
bool flag ;

void insert (char *s){
    Node *p = root ;
    for (int i = 0; s[i]; i++){
        int id = s[i] - '0' ;
        if (p -> next[id] == NULL){
            p ->flag1 = 1;
            p -> next[id] = new Node() ;
        }
        p -> flag1 = 1;
        p = p -> next[id] ;
        if (p -> flag2 == -1) flag = 1;
    }
    p -> flag2 = -1;
    if (p -> flag1) flag = 1;
}

void del (Node *p){
    for (int i = 0; i < 10; i++){
        if (p -> next[i] != NULL){
            del(p -> next[i]) ;
        }
    }
    delete p ;
}

int main (){
    int n ,m ;
    char s[maxn] ;
    scanf("%d", &m);
    while (m--){
        flag = 0;
        root = new Node();
        scanf("%d", &n);
        getchar() ;
        while (n--){
            gets(s) ;
            if (flag) continue ;
            insert(s);
//            cout << "text\n" ;
        }
        if (!flag) puts("YES");
        else puts("NO");
        del(root) ;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值