hdu1298(字典树+dfs)

T9

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3294    Accepted Submission(s): 1238


Problem Description
A while ago it was quite cumbersome to create a message for the Short Message Service (SMS) on a mobile phone. This was because you only have nine keys and the alphabet has more than nine letters, so most characters could only be entered by pressing one key several times. For example, if you wanted to type "hello" you had to press key 4 twice, key 3 twice, key 5 three times, again key 5 three times, and finally key 6 three times. This procedure is very tedious and keeps many people from using the Short Message Service.

This led manufacturers of mobile phones to try and find an easier way to enter text on a mobile phone. The solution they developed is called T9 text input. The "9" in the name means that you can enter almost arbitrary words with just nine keys and without pressing them more than once per character. The idea of the solution is that you simply start typing the keys without repetition, and the software uses a built-in dictionary to look for the "most probable" word matching the input. For example, to enter "hello" you simply press keys 4, 3, 5, 5, and 6 once. Of course, this could also be the input for the word "gdjjm", but since this is no sensible English word, it can safely be ignored. By ruling out all other "improbable" solutions and only taking proper English words into account, this method can speed up writing of short messages considerably. Of course, if the word is not in the dictionary (like a name) then it has to be typed in manually using key repetition again.


Figure 8: The Number-keys of a mobile phone.


More precisely, with every character typed, the phone will show the most probable combination of characters it has found up to that point. Let us assume that the phone knows about the words "idea" and "hello", with "idea" occurring more often. Pressing the keys 4, 3, 5, 5, and 6, one after the other, the phone offers you "i", "id", then switches to "hel", "hell", and finally shows "hello".

Write an implementation of the T9 text input which offers the most probable character combination after every keystroke. The probability of a character combination is defined to be the sum of the probabilities of all words in the dictionary that begin with this character combination. For example, if the dictionary contains three words "hell", "hello", and "hellfire", the probability of the character combination "hell" is the sum of the probabilities of these words. If some combinations have the same probability, your program is to select the first one in alphabetic order. The user should also be able to type the beginning of words. For example, if the word "hello" is in the dictionary, the user can also enter the word "he" by pressing the keys 4 and 3 even if this word is not listed in the dictionary.
 

Input
The first line contains the number of scenarios.

Each scenario begins with a line containing the number w of distinct words in the dictionary (0<=w<=1000). These words are given in the next w lines. (They are not guaranteed in ascending alphabetic order, although it's a dictionary.) Every line starts with the word which is a sequence of lowercase letters from the alphabet without whitespace, followed by a space and an integer p, 1<=p<=100, representing the probability of that word. No word will contain more than 100 letters.

Following the dictionary, there is a line containing a single integer m. Next follow m lines, each consisting of a sequence of at most 100 decimal digits 2-9, followed by a single 1 meaning "next word".
 

Output
The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1.

For every number sequence s of the scenario, print one line for every keystroke stored in s, except for the 1 at the end. In this line, print the most probable word prefix defined by the probabilities in the dictionary and the T9 selection rules explained above. Whenever none of the words in the dictionary match the given number sequence, print "MANUALLY" instead of a prefix.

Terminate the output for every number sequence with a blank line, and print an additional blank line at the end of every scenario.
 

Sample Input
  
  
2 5 hell 3 hello 4 idea 8 next 8 super 3 2 435561 43321 7 another 5 contest 6 follow 3 give 13 integer 6 new 14 program 4 5 77647261 6391 4681 26684371 77771
 

Sample Output
Scenario #1:
i
id
hel
hell
hello

i
id
ide
idea


Scenario #2:
p
pr
pro
prog
progr
progra
program

n
ne
new

g
in
int

c
co
con
cont
anoth
anothe
another

p
pr
MANUALLY
MANUALLY


这道题简直是超级有意思 ~~

先讲讲意思 :

这道题是这样的  给你一个用户平时输入的一些单词 然后给你一个这种情景 就是用户用九键键入了一些信息  然后让你猜出用户最可能想输入什么信息 然后把这个东西输出出出来  是不是有点智能的感觉  去猜人心里想的东西是什么


其实如果你明白原理的话也就没有这么高大上了 就是输出频率最高的单词



讲讲思路吧:

首先输入字符串 字典树建树没啥问题  然后读入用户的输入数字串 dfs枚举用户可能要输入的所有字符串  在枚举的过程中需要注意一个剪枝

这个剪枝非常重要  如果你枚举到了一个边号为零的边 那你还有没有必要继续往更深的地方枚举呢  没有必要对吧 所以这个return很重要  我TLE无数发才注意到这个问题~~

然后格式也很蛋疼


#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 100005;

int tree[N][26];
int nums[N] , cnt;
string key_value[10];
string A[110] ;
char str[120], length_qstr;

void Insert(char *str, int value)
{
	int i = 0 , k = 0;
	while (str[i]) {
		int pos = str[i ++] - 'a';
		if (tree[k][pos] == 0)
			tree[k][pos] = cnt++;
		k = tree[k][pos];
		nums[k] += value;
	}
}

int Find(char *str)
{
	int i = 0, k = 0;
	while (str[i]) {
		int pos = str[i ++] - 'a';
		if (tree[k][pos] == 0)
			return 0;
		k = tree[k][pos];
	}
}
int find_value(string str)
{
  //  cout <<str << endl;
	int length_str = str.length();
	int i = 0, k = 0;
	for (int i = 0; i < length_str; i ++) {
		if(str[i] == '\n')continue;
		int pos = str[i] - 'a';
		if (tree[k][pos] == 0)
			return 0;
		k = tree[k][pos];
	}
	return nums[k];
}
void dfs(string temp)
{
//	
	int length_temp = temp.length();
	if(length_temp > length_qstr)return ;
	if(find_value(temp) == 0 && length_temp) {
		return ;
	} 
	if(find_value(temp) > find_value(A[length_temp])) {
		//	if(judge(temp))
			A[length_temp] = temp;
		}
	string qq = temp;
	for (int i = 0; i < key_value[str[length_temp ] - '0'].length(); i ++) {
		qq += key_value[str[length_temp ] - '0'][i];
	//	cout <<key_value[str[length_temp ] - '0'][i] << " ~~~ " << qq << endl;
	//	cout << str[length_temp ] - '0' << "   duiyin   " <<key_value[str[length_temp ] - '0'][i] << endl;
		dfs(qq);
		qq = temp;
	}
	return ;
}
int main()
{
	int _, Case = 1;
	for (int i = 0; i < 10; i ++) 
		key_value[i].clear();
	key_value[2] = "abc";
	key_value[3] = "def";
	key_value[4] = "ghi";
	key_value[5] = "jkl";
	key_value[6] = "mno";
	key_value[7] = "pqrs";
	key_value[8] = "tuv";
	key_value[9] = "wxyz";
	scanf("%d",&_);
	while ( _ -- ) {
        cnt = 1;
		memset(tree , 0, sizeof(tree));
		memset(nums , 0, sizeof(nums));
		
		int n , value,  m;
		scanf("%d",&n);
		for (int i = 0; i < n; i ++) {
			scanf("%s%d",str , &value);
			Insert(str , value);
		}
		scanf("%d",&m);
		cout << "Scenario #"<< Case++ << ":" << endl;
		for (int i = 0; i < m; i ++) {
			scanf("%s",str);
			string ans = string(str);
			string temp;
		//	printf("GG\n");
			temp.clear();
			length_qstr = strlen(str);
		//	A.clear();
			for(int i = 0; i < 105; i ++) {
				A[i].clear();
			} 
			dfs(temp);
			int ppp = ans.length();
			for (int i = 1; i < ppp; i ++) {
				if(A[i].length())
					cout << A[i] << endl;
				else 
					printf("MANUALLY\n");
			//	break;
			}
			puts("");
		//	string qqq = "hello";
		//	cout << find_value(qqq) << endl;
		}
		puts("");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值