Master-Mind Hints

Description
MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.
In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.
In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.
A match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 , such that tex2html_wrap_inline45 . Match (i,j) is called strong when i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.
Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input
The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.
Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum value for N will be 1000.
Output
The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.
Sample Input
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0
Sample Output
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)
这个题目就是以前玩的猜数字的游戏,第一个数字表示位置数字都对的个数,第二数字表示数字对了,但是位置不对的个数。
直接扫一遍模拟判断就好了。

    #include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<queue>
#include<algorithm>
using namespace std;
int a[1005], b[1005];
int dp1[10], dp2[10], dp3[10], ans[1005], ans1[1005];
int min(int a, int b)
{
    return a < b ? a : b;
}
int main()
{
    int i, j, m, n, leap, temp = 1;
    while (scanf("%d", &n) != EOF)
    {
        if (n == 0)break;
        memset(dp1, 0, sizeof(dp1));
        for (i = 1; i <= n; i++)
        {
            cin >> a[i];
            dp1[a[i]]++;
        }
        leap = 1;
        j = 1;
        while (leap)
        {
            leap = 0; ans[j] = 0; ans1[j] = 0;
            memset(dp2, 0, sizeof(dp2));
            memset(dp3, 0, sizeof(dp3));
            for (i = 1; i <= n; i++)
            {
                cin >> b[i];
                if (b[i] == a[i])
                {
                    ans[j]++;
                    dp3[b[i]]++;
                }
                else
                    dp2[b[i]]++;
                if (b[i])
                    leap = 1;
            }
            if (leap)
            {
                for (i = 1; i <= 9; i++)
                {
                    ans1[j] = ans1[j] + min(dp1[i] - dp3[i], dp2[i]);
                }
                j++;
            }
        }
        cout << "Game " << temp << ":" << endl;
        for (i = 1; i < j; i++)
            cout << "    (" << ans[i] << "," << ans1[i] << ")" << endl;
        temp++;

    }   
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值