1127 ZigZagging on a Tree (30 分) 后序和中序遍历建树后输出Z字形层次遍历

1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题意:后序和中序遍历建树后输出Z字形层次遍历 

思路:建树把结点的左右儿子存在l和r数组中,因为要z字形层次遍历输出,所以我先把深搜跑了一遍深度,知道每个结点在第几层,然后正常的用queue跑层次遍历,把每个结点层在他相应的深度的vector里,然后根据深度的奇偶跑Z字形。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<sstream>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int post[1005],in[1005];
int l[1005],r[1005];
int dfs(int postl,int postr,int inl,int inr)
{
	if(postl>postr) return -1;
	int root=post[postr];
	int pos=inl;
	while(in[pos]!=root) pos++;
	int cnt=pos-inl;
	l[root]=dfs(postl,postl+cnt-1,inl,pos-1);
	r[root]=dfs(postl+cnt,postr-1,pos+1,inr);
	return root;
}
int le[1005],maxl;
void level(int root,int h)
{
	if(root==-1)return;
	le[root]=h;
	maxl=max(maxl,h);
	if(l[root]!=-1) level(l[root],h+1);
	if(r[root]!=-1) level(r[root],h+1);
}
int main()
{
	int n,i,j;
	memset(l,-1,sizeof l);
	memset(r,-1,sizeof r);
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	scanf("%d",&in[i]);
	for(i=1;i<=n;i++)
	scanf("%d",&post[i]);
	int root=post[n];
	dfs(1,n,1,n);
	level(root,1);
	queue<int> q;
	vector<int> v[1005]; 
	q.push(root);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		v[le[u]].push_back(u);
		if(l[u]!=-1)q.push(l[u]);
		if(r[u]!=-1)q.push(r[u]);
	}
	printf("%d",root);
	for(i=2;i<=maxl;i++)
	{
		if(i%2==0)
		{
			for(j=0;j<v[i].size();j++)
			printf(" %d",v[i][j]);
		}	
		else
		{
			for(j=v[i].size()-1;j>=0;j--)
			printf(" %d",v[i][j]);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值