【PAT 甲级】1127 ZigZagging on a Tree(30 分)(已知二叉树中序后序序列,求交替层序序列)

25 篇文章 0 订阅

题目链接

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题意:给定长度为n的后序序列和中序序列,输出交替层序序列。

思路:这一题和【PAT 甲级】1020 Tree Traversals (25)(25 分)不同的是,本题是交替层序遍历。所以这里直接用vector存储较好。

代码:


#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
const int N = 30+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;
const int T=3;

struct Node {
    int data;
    Node *lchild,*rchild;
};
int post[N],in[N],n;
queue<Node*>que;
Node* root;
vector<vector<int> >bt(N);
///array1[]为中序序列,array2[]为后序序列
void build(int n,int array1[],int array2[],const int depth) {

    if(n<=0)
        return ;
    int i=0;
    while(array1[i]!=array2[n-1]) {
        i++;///找根
    }
    bt[depth].push_back(array1[i]);
    build(i,array1,array2,depth+1);
    build(n-i-1,array1+i+1,array2+i,depth+1);
}

void bfs() {
    cout<<bt[0][0];
    bool flag=0;
    for(int i=1; i<bt.size(); i++) {
        if(flag) {
            for(int j=bt[i].size()-1; j>=0; j--) {
                cout<<" "<<bt[i][j];
            }
        } else {
            for(int j=0; j<bt[i].size(); j++) {
                cout<<" "<<bt[i][j];
            }
        }
        flag = !flag;
    }
}
int main() {
    cin>>n;
    for(int i=0; i<n; i++)
        cin>>in[i];
    for(int i=0; i<n; i++)
        cin>>post[i];
    build(n,in,post,0);
    bfs();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值