1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题意:给出n个人,m个查询。n个人的信息有考试种类type,座位号Site,日期data,随机数字num组成,最后是分数。

给出3种询问,1:考试种类为A/B/T的人的排序,先按分数排,再按前面一串的字典序排。

2:座位号为x的人有多少个,其相加总分是多少。

3:日期为x的人座位号分类,按照出现次数多的排序,一样都时候按座位号字典序排。

思路:暴力模拟,用结构体存每个人的信息,输出的时候注意3的时候,日期可能为“020202”,则要%06d输出。

还有1排序要放在while(m--)外面,不然会超时。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<sstream>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
struct sb
{
	char type;
	string a;
	int site;
	int date;
	int num;
	int score;
}p[10005];
struct sb3
{
	int num,sum;
}pp[10005];
bool cmp1(sb u,sb w)
{
	//if(u.type<w.type)
	//return u.type<w.type;
	if(u.score!=w.score)
	return u.score>w.score;
	return u.a<w.a;
}
bool cmp3(sb3 u,sb3 w)
{
	if(u.sum!=w.sum)
	return u.sum>w.sum;
	return u.num<w.num;
}
int main()
{
	int n,m,i,j,x,y,o=1;
	char c;
	scanf("%d%d",&n,&m);
	for(i=0;i<n;i++)
	{
		cin>>p[i].a>>p[i].score;
		p[i].type=p[i].a[0];
		p[i].site=(p[i].a[1]-'0')*100+(p[i].a[2]-'0')*10+(p[i].a[3]-'0');
		p[i].date=(p[i].a[4]-'0')*100000+(p[i].a[5]-'0')*10000+(p[i].a[6]-'0')*1000+(p[i].a[7]-'0')*100+(p[i].a[8]-'0')*10+(p[i].a[9]-'0');
		p[i].num=(p[i].a[10]-'0')*100+(p[i].a[11]-'0')*10+(p[i].a[12]-'0');
	}
	sort(p,p+n,cmp1);
	while(m--)
	{
		scanf("%d ",&x);		
		if(x==1)
		{
			int f=0;
			scanf("%c",&c);			
			printf("Case %d: %d %c\n",o++,x,c);
			for(i=0;i<n;i++)
			{
				if(p[i].type==c)
				{
					f=1;
					cout<<p[i].a<<" "<<p[i].score<<endl;
				}			
			}
			if(f==0)
			printf("NA\n");
		}
		else if(x==2)
		{
			scanf("%d",&y);
			printf("Case %d: %d %d\n",o++,x,y);
			int s=0,sum=0;
			for(i=0;i<n;i++)
			{
				if(p[i].site==y)
				{
					s++;
					sum+=p[i].score;
				}
			}
			if(s==0)
			printf("NA\n");
			else
			printf("%d %d\n",s,sum);		
		}
		else if(x==3)
		{
			scanf("%d",&y);
			int op[1000]={0},oo=0;
			for(i=0;i<n;i++)
			{
				if(p[i].date==y)
				{
					op[p[i].site]++;
				}
			}
			for(i=101;i<=999;i++)
			{
				if(op[i]!=0)
				{
					//cout<<i<<op[i]<<endl;
					pp[oo].num=i;
					pp[oo].sum=op[i];
					oo++;
				}
			}
			printf("Case %d: %d %06d\n",o++,x,y);
			if(oo==0)
			printf("NA\n");
			else
			{
				sort(pp,pp+oo,cmp3);
				for(i=0;i<oo;i++)
				printf("%d %d\n",pp[i].num,pp[i].sum);
			}
			
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值