1153 Decode Registration Card of PAT (25分)

121 篇文章 0 订阅
115 篇文章 0 订阅

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

 

题解:

边读入边按要求处理数据分类保存。查询时直接输出。

#include <iostream>
#include <string>
#include <unordered_map>
#include <vector>
#include <algorithm>

using namespace std;

const int N = 10010;
const int S = 1010;

struct Node
{
	string id;
	int score;
}node[N];

struct Site
{
	int cnt, sum;
	Site() {
		cnt = 0;
		sum = 0;
	}
}site[S];

bool cmp(Node a, Node b) {
	if (a.score != b.score) return a.score > b.score;
	else return a.id < b.id;
}

vector<Node> la, lb, lt;
unordered_map<string, unordered_map<string, int>> dateHash;
int main() {
	int n, q;
	cin >> n >> q;
	for (int i = 0; i < n; i++)
	{
		Node t;
		cin >> t.id >> t.score;

		if (t.id[0] == 'A') la.push_back(t);
		if (t.id[0] == 'B') lb.push_back(t);
		if (t.id[0] == 'T') lt.push_back(t);

		string s = t.id.substr(1, 3);
		site[stoi(s)].cnt++;
		site[stoi(s)].sum += t.score;

		string date = t.id.substr(4, 6);
		dateHash[date][s]++;
	}

	sort(la.begin(), la.end(), cmp);
	sort(lb.begin(), lb.end(), cmp);
	sort(lt.begin(), lt.end(), cmp);

	for (int i = 1; i <= q; i++)
	{
		string t, c;
		cin >> t >> c;

		printf("Case %d: %s %s\n", i, t.c_str(), c.c_str());

		if (t == "1")
		{
			if (c[0] == 'A') {
				if (la.empty()) puts("NA");
				else
					for (auto it : la) printf("%s %d\n", it.id.c_str(), it.score);
			}
			if (c[0] == 'B') {
				if (lb.empty()) puts("NA");
				else
					for (auto it : lb) printf("%s %d\n", it.id.c_str(), it.score);
			}
			if (c[0] == 'T') {
				if (lt.empty()) puts("NA");
				else
					for (auto it : lt) printf("%s %d\n", it.id.c_str(), it.score);
			}
		}
		else if (t == "2")
		{
			int idx = stoi(c);
			if (site[idx].cnt == 0) puts("NA");
			else printf("%d %d\n", site[idx].cnt, site[idx].sum);
		}
		else
		{
			vector<pair<int, string>> rooms;
			for (auto item : dateHash[c]) rooms.push_back({ -item.second, item.first });

			sort(rooms.begin(), rooms.end());
			if (rooms.empty()) puts("NA");
			else
				for (auto room : rooms)
					printf("%s %d\n", room.second.c_str(), -room.first);
		}
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值