1072 Gas Station (30 分) dijstra最短路

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

题目大意:从m个加油站里面选取1个站点,让他离居民区的最近的人最远,并且没有超出服务范围ds之内。

如果有很多个最远的加油站,输出距离所有居民区距离平均值最小的那个。

如果平均值还是一样,就输出按照顺序排列加油站编号最小的那个。

思路:读数据的时候要用getnum处理一下。

因为加油站之间也可以有路,所以最短路径计算的时候也要把加油站算上。

所以就是对n+m个点进行Dijkstra计算最短路径。

算得最短路径后要判断1是否超出服务范围

2离其最近的点最远

3平均值最小

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <vector>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
int ma[1500][1500];
int dis[1500];
int vis[1500];
int n,m; 
int getnum(string s)
{
	int x=0,j;
	if(s[0]=='G') 
	{
		for(j=1;j<s.length();j++)
		x=x*10+s[j]-'0';
		x+=n;
	} 
	else
	{
		for(j=0;j<s.length();j++)
		x=x*10+s[j]-'0';
	} 
    return x;
}
int main()
{
	int k,ds,i,j,l;
	scanf("%d%d%d%d",&n,&m,&k,&ds);
	memset(ma,INF,sizeof ma);
	for(i=0;i<k;i++) 
	{
        int len;
        string s,t;
        cin>>s>>t>>len;
        int x=getnum(s);
        int y=getnum(t);
        if(ma[x][y]>len)
        ma[x][y]=ma[y][x]=len;
	}
	double maxD=-1,minAvg=INF; //最短距离最大 & 平均距离最小 
	int res=-1; 
	for(l=n+1;l<=n+m;l++)
	{
		memset(dis,INF,sizeof dis);
		memset(vis,0,sizeof vis);
		dis[l]=0;
		for(i=1;i<=n+m;i++)
		{
			int d=INF,next=-1;
			for(j=1;j<=n+m;j++)
			{
				if(vis[j]==0&&dis[j]<d)
				{
					d=dis[j];
					next=j;
				}
			}
			if(next==-1)break;
			vis[next]=1;
			for(j=1;j<=n+m;j++)
			{
				if(vis[j]==0&&dis[j]>dis[next]+ma[next][j])
				{
					dis[j]=dis[next]+ma[next][j];
				}
			}
		}
		
		double minD=INF,avg=0;
		for(i=1;i<=n;i++)
		{
			if(dis[i]>ds)//超出范围
			{
				minD=-1;
				break;
			} 
			if(dis[i]<minD)
			minD=dis[i];//找到最小的距离
			avg+=dis[i]; 
		}
		//if(minD==-1)break;
		if(minD!=-1)
		{
			avg=1.0*avg/n;
			//printf("%d : %.2lf %.2lf\n",l,minD,avg);
			if(minD>maxD||(minD==maxD&&avg<minAvg))
			{
				res=l;
				maxD=minD;
				minAvg=avg;
			}
		}		
	}
	if(res==-1) 
	printf("No Solution\n");
	else
	printf("G%d\n%.1lf %.1lf\n",res-n,maxD,minAvg);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值