1043 Is It a Binary Search Tree (25 分) 建立BST对比前序输出后序

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

用给定的序列建立BST,比较这个序列是否与该BST前序or镜像前序相同

如果相同输出YES,打印该树的后序遍历。否则输出NO。

 

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <math.h>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
struct Node
{
	int val;
	struct Node *l,*r;
	Node()
	{
		val=-1001;
		l=r=NULL;
	}
};
void insert(struct Node* root,int x)
{
	if(root->val==-1001)
	{
		root->val=x;
		return;
	}
	if(x<root->val)
	{
		if(root->l==NULL)root->l=new Node;
		insert(root->l,x);
	}
	else
	{
		if(root->r==NULL)root->r=new Node;
		insert(root->r,x);
	}
}
vector<int> k,pre,mpre,post,mpost;
void preorder(Node* root)
{
	if(root==NULL) return;
	pre.push_back(root->val);
	preorder(root->l);
	preorder(root->r);
}
void mpreorder(Node* root)
{
	if(root==NULL) return;
	mpre.push_back(root->val);
	mpreorder(root->r);
	mpreorder(root->l);
}
void postorder(Node* root)
{
	if(root==NULL) return;
	postorder(root->l);
	postorder(root->r);
	post.push_back(root->val);
}
void mpostorder(Node* root)
{
	if(root==NULL) return;
	mpostorder(root->r);
	mpostorder(root->l);
	mpost.push_back(root->val);
}
int main()
{
	int n,x,i;
	Node *root=new Node;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&x);
		k.push_back(x);
		insert(root,x);
	}
	preorder(root);
	mpreorder(root);   
	postorder(root);
	mpostorder(root);
    
	if(k==pre)
	{
		printf("YES\n");
		for(i=0;i<post.size();i++)
		{
			if(i)printf(" ");
			printf("%d",post[i]);
		}
		printf("\n");
	}
	else if(k==mpre)
	{
		printf("YES\n");
		for(i=0;i<mpost.size();i++)
		{
			if(i)printf(" ");
			printf("%d",mpost[i]);
		}
		printf("\n");
	}
	else
	printf("NO\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是用 C 语言实现的代码: ```c #include <stdio.h> #include <stdbool.h> #include <stdlib.h> /* 二叉树结点 */ struct TreeNode { int val; struct TreeNode* left; struct TreeNode* right; }; /* 队列结点 */ struct QueueNode { struct TreeNode* data; struct QueueNode* next; }; /* 队列 */ struct Queue { struct QueueNode* front; struct QueueNode* rear; }; /* 创建队列 */ struct Queue* createQueue() { struct Queue* queue = (struct Queue*)malloc(sizeof(struct Queue)); queue->front = queue->rear = NULL; return queue; } /* 判断队列是否为空 */ bool isQueueEmpty(struct Queue* queue) { return queue->front == NULL; } /* 入队 */ void enqueue(struct Queue* queue, struct TreeNode* data) { struct QueueNode* newNode = (struct QueueNode*)malloc(sizeof(struct QueueNode)); newNode->data = data; newNode->next = NULL; if (isQueueEmpty(queue)) { queue->front = queue->rear = newNode; } else { queue->rear->next = newNode; queue->rear = newNode; } } /* 出队 */ struct TreeNode* dequeue(struct Queue* queue) { if (isQueueEmpty(queue)) { return NULL; } else { struct TreeNode* data = queue->front->data; struct QueueNode* temp = queue->front; queue->front = queue->front->next; if (queue->front == NULL) { queue->rear = NULL; } free(temp); return data; } } /* 判断是否为完全二叉树 */ bool isCompleteTree(struct TreeNode* root) { if (root == NULL) { return true; } struct Queue* queue = createQueue(); enqueue(queue, root); bool flag = false; while (!isQueueEmpty(queue)) { struct TreeNode* temp = dequeue(queue); if (temp->left) { if (flag) { return false; } enqueue(queue, temp->left); } else { flag = true; } if (temp->right) { if (flag) { return false; } enqueue(queue, temp->right); } else { flag = true; } } return true; } /* 创建二叉树 */ struct TreeNode* createTree() { int val; scanf("%d", &val); if (val == -1) { return NULL; } struct TreeNode* root = (struct TreeNode*)malloc(sizeof(struct TreeNode)); root->val = val; root->left = createTree(); root->right = createTree(); return root; } /* 主函数 */ int main() { struct TreeNode* root = createTree(); if (isCompleteTree(root)) { printf("It is a complete binary tree.\n"); } else { printf("It is not a complete binary tree.\n"); } return 0; } ``` 原理: 完全二叉树(Complete Binary Tree)是指除了最后一层外,其他层的结点数都达到了最大值,最后一层的结点都集在左侧。而对于一棵二叉树,如果它的层数为 h,那么它最多有 $2^h-1$ 个结点。因此,我们可以利用层序遍历的方式,对二叉树进行遍历,如果遇到某个结点缺少左子结点或右子结点,那么后续的结点必须全部为叶子结点,否则这棵二叉树就不是完全二叉树。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值