1020 Tree Traversals (25 分) 给出后序和中序遍历,输出层序遍历

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

突然发现这道题以前写过:https://blog.csdn.net/TheWise_lzy/article/details/79394852

但是方法不一样 嘤嘤嘤

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
struct node 
{
    int index,value;
}p;
int post[100],in[100];
vector<node> ans;
bool cmp(node a, node b) 
{
    return a.index<b.index;
}
void pre(int root,int start,int end,int index) 
{
    if (start>end) return;
    int i=start;
    while(i<end&&in[i]!=post[root]) i++;
    p.index=index;
    p.value=post[root];
    ans.push_back(p);
    pre(root-1-end+i,start,i-1,2*index+1);
    pre(      root-1,  i+1,end,2*index+2);
}
int main() 
{
    int n,i;
    scanf("%d", &n);
    for(i=0;i<n;i++) 
    scanf("%d",&post[i]);
    for(i=0;i<n;i++) 
    scanf("%d",&in[i]);
    pre(n-1,0,n-1,0);
    sort(ans.begin(),ans.end(),cmp);
    for(i=0;i<ans.size();i++) 
    {
        if(i)printf(" ");
        printf("%d",ans[i].value);
    }
    printf("\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值