PAT 1020. Tree Traversals (25)(树的构造与遍历,通过后序中序输出层次遍历)

题目

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

解题思路

  • 1.后序遍历即前面是左,中间的为右,最后面的为根。中序遍历即前面是左,中间的为根,后面的为右。
  • 2.后序遍历的最后一个数是树的根,在中序遍历中找到根,那么它的左边就是它的左子树,右边就是他的右子树,而且可以知道它的左右子树各多少个,那么与之相同的,后序遍历中的前多少个就是它的左子树,后面多少个就是它的右子树(不包括根了)。
  • 3.用pl,pr来记录后续遍历数组中的左右位置,然后通过中续遍历中查找根,进而可以到有多少左右子树元素的个数,那么这时候就可以把后序遍历数组分为三个部分,pl k1 pr-1,pl到k1即为它的左子树,这时候中序遍历数组也可以分为三个部分,il到k2-1, k2,k2到ir,其中il到k2-1即为它的左子树,这时候递归使用构造程序分别构造出左右子树即可。

AC代码

#include <cstdio>
#include <cstdlib>
#include <queue>

using namespace std;

const int maxx = 32;

typedef struct node{
    node *le;
    node *ri;
    int data;
} *Tree;

Tree root;

int pos[maxx],in[maxx];


void printLevelOrder(Tree root){
    queue<Tree> que;
    Tree tr = NULL;
    que.push(root);
    bool flg = true;
    while(!que.empty()){
        tr = (Tree )que.front();
        que.pop();
        if(tr==NULL)continue;
        if(flg){
            printf("%d",tr->data);
            flg = false;
        }else{
            printf(" %d",tr->data);
        }
        que.push(tr->le);
        que.push(tr->ri);
    }
    printf("\n");
}

//构造树pl为后序序列的左边界pr为其右边界
//il为中续遍历的左边界ir为其右边界
Tree buildTree(int pl,int pr,int il,int ir){
    if(pl>pr)return NULL;
    int p = il;
    while(in[p]!=pos[pr])++p;

    //Tree tree = (Tree *)malloc(sizeof(Tree));
    Tree tree = new node();
    tree->data = pos[pr];
//    tree->le = buildTree(pl,pr-ir+p-1,il,p-1);
//    tree->ri = buildTree(pr-ir+p,pr-1,p+1,ir);

        tree->le = buildTree(pl,pl+p-il-1,il,p-1);
        tree->ri = buildTree(pl+p-il,pr-1,p+1,ir);
    return tree;
}

int main(){
    int n,i;
    Tree root;

    scanf("%d",&n);
    for(i=0;i<n;++i){
        scanf("%d",&pos[i]);
    }
    for(i=0;i<n;++i){
        scanf("%d",&in[i]);
    }
    root=buildTree(0,n-1,0,n-1);
    printLevelOrder(root);
    return 0;
}

附通过前序中序遍历构造整个树的代码

#include<iostream>

using namespace std;
typedef struct node{
    int data;
    node *left,*right;
}* Tree;
int fo[100],in[100];

Tree build(int fl,int fr,int il,int ir){
    if (fr < fl) {
        return NULL;
    }
    Tree root = new node();
    int i = il;
    for (; i <= ir; ++i) {
        if (in[i] == fo[fl]) {
            break;
        }
    }
    int left_len = i - il;
    root->data = fo[fl];
    root->left = build(fl+1,fl+left_len,il,i-1);
    root->right = build(fl+left_len+1,fr,i+1,ir);
    return root;
}
bool flag = false;
void print_post(Tree root){
    if (root == NULL) {
        return;
    }
    print_post(root->left);
    print_post(root->right);
    if (!flag) {
        cout << root->data;
        flag = true;
    }else {
        cout << " " << root->data;
    }
}
int main(int argc, char *argv[])
{
    int n ;
    cin >> n;
    for (int i = 0; i < n; ++i) {
        cin >> fo[i];
    }
    for (int i = 0; i < n; ++i) {
        cin >> in[i];
    }
    Tree root;
    root = build(0,n-1,0,n-1);
    print_post(root);
    cout << endl;
    return 0;
}
测试
7   
1 2 4 5 3 6 7
4 2 5 1 6 3 7 
输出 :
4 5 2 6 7 3 1
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值