1145 Hashing - Average Search Time (25 分) 建立Hash表并输出平均查询次数

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

题意:给定maxn(表的大小),插入n个数,查询m个数。

maxn应为素数,若给定的值不是素数,则更新为比他大的最小的素数。

若插入n个数时有数无法插入则输出,最后输出查询m个数的平均次数。 

思路:先处理maxn,更新为素数。

之后插入数的时候散列,若插不进则输出。

查询时也用同样的循环查询。

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <vector>
#include <queue>
#include <math.h>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
int a[100050];
bool prime(int x)
{
	for(int i=2;i<=sqrt(x);i++)
	{
		if(x%i==0)return false;
	}
	return true;
}
int main()
{
	int maxn,n,m,x,i,j;
	memset(a,0,sizeof a);
	scanf("%d%d%d",&maxn,&n,&m);
	while(!prime(maxn)) maxn++;//找到大于maxn的素数 
	//printf("%d\n",maxn);
	for(i=0;i<n;i++)
	{
		scanf("%d",&x);
		int flag=1;
		for(j=0;j<maxn;j++)
		{
			int pos=(x+j*j)%maxn;
			if(a[pos]==0)
			{
				flag=0;
				a[pos]=x;
				break;
			}
		}
		if(flag) printf("%d cannot be inserted.\n",x);
	}
	double sum=0;
	for(i=0;i<m;i++)
	{
		scanf("%d",&x);
		int cnt=1;
		for(j=0;j<maxn;j++)
		{
			int pos=(x+j*j)%maxn;
			if(a[pos]==x||a[pos]==0)
			break;
			cnt++;
		}
		sum+=cnt;
	}
	printf("%.1lf\n",sum/m);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值