素数环问题之解题报告

                                            Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37065    Accepted Submission(s): 16337


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 


对于这个笔者的想法与大家一样也是通过先打印一张哈希表然后通过深搜(DFS)来解决这个问题;
但是在深搜过程中由于有很多判断条件,所以导致理解起来有点的难度,但是只要静下心来,你就会明白的。

代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define N 25

using namespace std;

int  prime[N],sign[N];   //sign来表示是否已访问过 ,prime来储存满足条件的数 
int  map[]={2,3,5,7,11,13,17,19,23,29,31,37}; //素数表提高效率 
int isprime[40];    //判断是否是素数 
int  n;

bool DFS(int x,int cur)
{
     prime[x] = cur;
     if(x==n-1)
     {
         if(!isprime[cur+1])
            return false;
         for(int i=0;i<n;++i){
             printf("%d",prime[i]);
             printf("%c",i==n-1?'\n':' ');
         }
         return false;
     }
     else
     {
         for(int i=2;i<=n;++i)
         {
            if(sign[i])   
               continue;
            sign[i] = 1;
            if(isprime[cur+i]&&DFS(x+1,i))
               return true;
            sign[i] = 0;
         }
     }
     return false;
}

int  main(void)
{
     while(~scanf("%d",&n))
     {
         memset(isprime,0,sizeof(isprime));
         for(int i=0;i<12;++i)
            isprime[map[i]] = 1;   //标记素数 
         int cas = 1;
         memset(sign,0,sizeof(sign));
         
         printf("Case %d:\n",cas++);
         DFS(0,1);
     }
     
     return 0;
} 

如果你还想做一些这类题来巩固你对于这类问题理解的话可以点击下面的链接:
(づ ̄3 ̄)づ╭❤~点一下我这个传送门吧


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值