Poj 2081 Recaman's Sequence之解题报告

                                                                                                                               Recaman's Sequence
Time Limit: 3000MS Memory Limit: 60000K
Total Submissions: 22363 Accepted: 9605

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

28

18658


对于这题的正确做法就是模拟加暴力Dp;

在DP的时候一定记得考虑时间复杂度的问题;

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

const int maxn = 500000+10;
int a[maxn];
bool used[3012500];

int  main(void)
{
     int k,i,j;
     
     a[0] = 0;
     memset(used,0,sizeof(used));
     used[0] = 1;
     for(i=1;i<=500000;++i)
     {
        if(a[i-1]-i>0&&!used[a[i-1]-i])  a[i] = a[i-1]-i;
        else    a[i] = a[i-1]+i;
        used[a[i]] = 1;
     }
     while(scanf("%d",&k),k!=-1)
     {
         
         cout<<a[k]<<endl;
     }
     
     return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值