题目链接:点击打开链接
Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
Sample Output
5 2
ps: 这道题求最大独立集,有个公式:最大独立集 = 节点数 - 最大匹配数。但此题有个坑就是男女编号是并没有分开的,也就是说,配对的可能是男男,女女,男女,三种情况。而其中是男女匹配的概率为二分之一,实际最大匹配数 = 所求最大匹配数/2。明白了这点就没什么难度了。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int p[505];
bool a[505][505];
bool vis[505];
int n,m,q,w,t;
bool find(int x)
{
for(int i=0; i<n; i++)
{
if( a[x][i] && !vis[i])
{
vis[i]=true;
if(p[i] == -1 )
{
p[i] = x;
return true;
}
else if ( find(p[i]) ) //如果此男生匹配的女生已经被标记
{ // 看前一次匹配的男生是否可以找到其他的女生匹配
p[i] = x; //如果可以就此次匹配继续
return true;
}
}
}
return false;
}
int main()
{
while(scanf("%d",&t) != EOF)
{
n=m=t;
memset(a,false,sizeof(a));
memset(p,-1,sizeof(p));
for(int i=0; i<t; i++)
{
scanf("%d: (%d)",&w,&q);
for(int j=0; j<q; j++)
{
int y;
scanf("%d",&y);
a[w][y]=true;
}
}
int ans = 0;
for(int i=0; i<m; i++)
{
memset(vis,false,sizeof(vis));
if( find(i) )
ans++;
}
printf("%d\n",n-ans/2) ; //最大独立集 = 节点数 - 最大匹配数
}
return 0;
}