Wall Painting HDU - 4810 (组合数学)

Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B. 
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with   different plans. 

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6. 
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him? 
You should tell Mr.Fang the answer from the first day to the n-th day.
Input
There are several test cases, please process till EOF. 
For each test case, the first line contains a single integer N(1 <= N <= 10  3).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.
Output
For each test case, output N integers in a line representing the answers(mod 10  6 +3) from the first day to the n-th day.
Sample Input
4
1 2 10 1
Sample Output
14 36 30 8
题意:给你n和k,求分别从n个中选择k个异或和

思路:首先知道0和1异或是不会影响结果的,只有1和1异或且1的个数是奇数的时候才会对结果产生影响,所以我们把每个数都转换成二进制,统计每一位上的1的个数,利用组合数学解决

队友写的。比赛的时候因为没有考虑只有一个数的时候,多家了一个空格,然后PE了半个小时

#include <iostream>
#include <cstdio>
#include <cstring>
#define ll long long
#define mod 1000003
using namespace std;

ll C[1005][1005];
ll data[1005];
ll wei[35];
ll n,up,sum;

void get_C()
{
    memset(C,0,sizeof(C));
    C[0][0]=C[1][0]=C[1][1]=1;
    for(ll i=2; i<=1001; i++)
    {
        C[i][0]=C[i][i]=1;
        for(ll j=1; j<i; j++)
        {
            C[i][j]=(C[i-1][j]+C[i-1][j-1])%mod;
        }
    }
}

void count_wei(ll x)
{
    int i=0;
    while(x)
    {
        if(x&1) wei[i]++;
        i++;
        if(i>up) up=i;
        x=x/2;
    }
}

void solve()
{
    if(n==1) printf("%I64d\n",sum);
    else printf("%I64d ",sum);
    ll ans;
    for(int i=2; i<=n; i++)
    {
        ans=0;
        for(int j=0; j<up; j++)
        {
            for(int k=1; k<=i&&k<=wei[j]; k+=2)
            {
                ans=(ans+((((C[wei[j]][k]*C[n-wei[j]][i-k])%mod)*((1<<j)%mod))%mod))%mod;
            }
        }
        if(i==n) printf("%I64d\n",ans);
        else  printf("%I64d ",ans);
    }
}

int main()
{
    get_C();
    while(cin>>n)
    {
        sum=0;
        up=0;
        memset(wei,0,sizeof(wei));
        for(int i=0; i<n; i++)
        {
            scanf("%I64d",&data[i]);
            count_wei(data[i]);
            sum=(sum+data[i])%mod;
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值