poj 2488A Knight's Journey(DFS+回溯)

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 46464 Accepted: 15812

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

[Submit]   [Go Back]   [Status]   [Discuss]


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
#define e exp(1.0)
//ios::sync_with_stdio(false);
//    auto start = clock();
//    cout << (clock() - start) / (double)CLOCKS_PER_SEC;
typedef long long ll;
typedef long long LL;
using namespace std;

const int maxn=30;
int vis[maxn][maxn];
int n,m;
int dx[8]={-2,-2,-1,-1,1,1,2,2};
int dy[8]={-1,1,-2,2,-2,2,-1,1};
//方向要按照字典序
struct node
{
    int x,y;
}p[maxn];
int flag;
void dfs(int x,int y,int step)
{
    if(flag) return ;
    p[step].x=x;
    p[step].y=y;
    if(step==n*m)
    {
        flag=1;
        return;
    }
    node a;
    for(int i=0;i<8;i++)
    {
        a.x=x+dx[i];
        a.y=y+dy[i];
        if(a.x>0 && a.x<=n && a.y>0 && a.y<=m && !vis[a.x][a.y])
        {
            vis[a.x][a.y]=1;
            dfs(a.x,a.y,step+1);
            vis[a.x][a.y]=0;
        }
    }
}
int main()
{
    int T;
    cin>>T;
    int cas=1;
    while(T--)
    {
        cin>>m>>n;
        memset(vis,0,sizeof(vis));
        memset(p,0,sizeof(p));
        vis[1][1]=1;
        flag=0;
        dfs(1,1,1);
        cout<<"Scenario #"<<cas++<<":"<<endl;
        if(flag)
        {
            for(int i=1;i<=n*m;i++)
                printf("%c%d",p[i].x-1+'A',p[i].y);
                //cout<<(char)(p[i].x-1-+'A')<<p[i].y;
            cout<<endl;
        }
        else
        {
            cout<<"impossible"<<endl;
        }
        if(T) cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值