Knight Moves

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

思路:

BFS,广搜

由于这是广搜,所以第一次判断出到达终点的步数就是最小的。

#include<iostream>
#include<string.h>
using namespace std;
#define N 300
bool v[N][N];
struct point
{
	int x;//行号 
	int y;//列号 
	int step;//步数 
}point[100000];
int d[8][2]={{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};//偏移数组 
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		int L,startx,starty,p,q;//startx,stary起点坐标,p,q终点坐标 
		scanf("%d\n%d %d\n%d %d",&L,&startx,&starty,&p,&q);
		//BFS
		//对起点start初始化 
		int head=1;
		int tail=1;
		memset(v,0,sizeof(v));//赋值0 
		v[startx][starty]=1; 
		point[tail].x =startx;
		point[tail].y =starty;
		point[tail].step =0;
		tail++;
		while(head<tail)//如果不符合就是点相同 
		{
			//使x,y分别为队首元素的行号和列号
			int x=point[head].x;
			int y=point[head].y;
			int step=point[head].step;
			//到终点的情况
			if(x==p&&y==q)
			{
				printf("%d\n",step);
				break;
			}
			//进行八个方向试探
			for(int k=0;k<8;k++)
			{
				//tx,ty是试探的点
				int tx,ty;
				tx=x+d[k][0];
				ty=y+d[k][1];
				//当试探的点未访问时
				if(tx>=0&&tx<L&&ty>=0&&ty<L&&v[tx][ty]==0)
				{
					//将该试探点入队
					v[tx][ty]=1;
					point[tail].x=tx;
					point[tail].y=ty;
					point[tail].step=step+1;
					tail++;
				} 
			}
			head++;
		} 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

TherAndI

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值