【HDU】Hdu 2955 (DP)

 

Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 

Sample Input

 

3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

 

Sample Output

 

2 4 6

 

 

这是一道动态规划问题,属于01背包问题可以用一个数组表示当可以偷到这么多的钱的时候的最大成功率是多少,(注意这里给出的是失败率,要将他给的失败率转化为成功率,给的数据时神坑,千万不要把失败率相加,否则会wa到哭)在最后看小于最大失败率的最大钱数是多少;就可以ac了:

 

代码:

 

#include <iostream>
#include<algorithm>
#include<cmath>
#include<cstring>

using namespace std;
int money[105];
float minp;
float flopro[105];
double maxmon[10005];
int backs,sum;
int main()
{
    int test;
    cin >> test;
    while ( test > 0 )
    {
        sum = 0;
        test--;
        cin >> minp >> backs;
        minp = 1- minp;///转化为最小成功率
        for ( int i = 0; i < backs; i++ )
        {
            cin >> money[ i ] >> flopro[ i ];
            flopro[i] = 1 - flopro[i];///转化为每件事情的成功率
            sum += money[i];
        }
        memset(maxmon,0,sizeof(maxmon));
        maxmon[0]=1.0;
        //vis[0] = 1;
        for ( int i = 0; i < backs; i++ )
        {
            for ( int j = sum ; j >= money[i]; j-- )
            {
                maxmon[ j ] = max( maxmon[ j - money[i]] * flopro[i], maxmon[ j ]);///找出抢这么多钱的最大成功率
            }
        }
        int ans = 0;
        for ( int i = sum; i >=0 ; i-- )
        {
            if (  maxmon[i] > minp )
            {
                ans = i;///找出大于最小成功率的抢的最多的钱;
                break;
            }

        }
        cout << ans << endl;
    }
}

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值