【POJ】poj 2828

 

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

 

 

 

线段树为题,题目大意:人们一个一个的来排队并插队,按人到来的顺序给出每个人插队的位置(插在第几个人后面),并告知每个人的id号,输出最终队伍的情况。

思路: 建立线段树,每一个节点表示这个区间上的空位置还有多少,将每个人的id和价值输入之后,和每个人的价值,从后往前计算,因为前面的排完队之后后面的还可能插队,导致计算量增大,最后一个人的位置肯定是他的id加一,继续确定倒数第二个人的位置,递推下去就可以得到答案:

代码:

 

/******************************************************
    二叉树问题,节点上的值记录的使这个区间剩余的空
位置,
******************************************************/
#include <iostream>
#include <cstdio>
#include<cstring>
#define MAX 200005
using namespace std;
int tree[MAX << 2];///记录这个区间还有多少空位置
int ans[MAX];///记录价值的顺序
int ticke[MAX];///
int val[MAX];///记录价值
void build ( int p,int l, int r )///建树和普通的二叉树一样
{
    if ( l == r ){ tree[p] = 1; return ; }///注意叶节点只有一个空位
    int mid = ( l + r ) >> 1;
    build ( p * 2, l , mid );
    build ( p * 2 + 1, mid + 1, r );
    tree[p] = tree[ 2 * p ] + tree [ 2 * p + 1 ];
}
void que ( int p , int l, int r, int pos, int val )
{
    tree[p]--;///要在这个区间放入一个值,那么这个区间的空位置就减去一个
    if ( l == r ) { ans[l] = val; return ;}
    int mid = ( l + r ) >> 1;
    if ( pos <= tree[2*p] )///如果左边的空位置少于需要的就放在右边
    {
        que(2*p,l,mid,pos,val);
    }
    else que(2*p+1,mid+1,r,pos-tree[2*p],val);
    //tree[p] = tree[2*p]+tree[2*p+1];
}
int main()
{
    //freopen("in.txt","r",stdin);
    int test;
    while ( cin >> test )
    {
        for ( int i = 0; i < test; i++ )
        {
            scanf( "%d %d",&ticke[i],&val[i]);
        }
        build(1,0,test-1);
        for ( int i = test-1; i >= 0; i-- )///注意要从后往前计算,因为前面的插入之后后面的会影响前面的,后面的位置是确定的
        {
            //cout << tree[i] << endl;
            que( 1, 0, test - 1,ticke[i]+1,val[i]);
        }
        for ( int i = 0; i < test; i++ )
        {
            //cout << tree[i] << endl;
            printf("%d%c",ans[i],i < test-1?' ':'\n');
        }
    }
}


还有一中费时间的做法,就是从后往前方,然后就是放前一个,如果放这个的时候他前面没有插队进入的他的位置就是id+1,如果插入的过的话就是最后插队进来的所以他的id要自增,代码如下:

 

 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct ticke
{
    int pos;
    int val;
}t[200005];
int vis[200005]={0};
int p[200005];
int test;
int main()
{
    //freopen("in.txt","r",stdin);
    while ( scanf("%d",&test) != EOF )
    {
        for ( int i = 0; i < test; i++ )
        {
            scanf( "%d %d",&t[i].pos,&t[i].val);
        }
        for ( int i = test-1;i >=0; i-- )
        {
            for ( int j = 1; j < test; j++ )
            {
                if ( j <= t[i].pos +1 && vis[j]==1)
                    ///如果j放过,并且j的位置小于i的位置(j是后面插队进入的),那么i的位置就自增
                    t[i].pos++;
                if ( j > t[i].pos + 1) break;
            }
            vis[t[i].pos+1] = 1;///i就放过了
            p[t[i].pos] = t[i].val;///p记录val的正确顺序;
        }
        for ( int i = 0; i < test; i++ )
        {
            printf("%d%c",p[i],i < test-1?' ':'\n');
            vis[i] = 0;
        }
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值