-
总时间限制:
- 1000ms 内存限制:
- 65536kB
-
描述
-
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
输入
-
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
输出
- For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case. 样例输入
-
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
样例输出
-
Case 1: 2 Case 2: 1
题目大致意思是,x轴为海岸线,上方有坐标为(x,y)的岛屿x,y为整数,已知雷达的探测范围为d(整数),问至少需要多少个雷达能他覆盖到所有的岛屿。如果有岛屿不能被探测到,则输出-1,否则输出最少雷达个数
思路:把雷达能探测到的位置转化为以,岛屿为圆心,d为半径的圆在x轴上截的长度区间(在此区间内可以探测到该岛屿,
把所有的区间按照升序排列,然后选择某个区间左端点,并且与其之前的没有被确定为已经被探测的区间的右端点进行比较,如果小于之前的点的右端点,则说明这个位置安放雷达可以探测到这些岛屿,继续这个过程,直到某个岛屿不能被探测,说明之前几个区间需要安放一个雷达,记录此时位置,并且下一轮从该位置记录比较。
此题巧妙之处就是,按照区间左端点升序排列,此时,后面的区间起始处已经默认小于之前的区间的左端点,此时只需要比较其起始点,是否也比右端点小就可以判断是否可以同时探测。
按照这个思想,我觉得,也可以按照右端点降序排列,此时之前的区间的右端点已经默认小于该点右端点,可以按照类似方法进行判断。
学习到了:数据读入时即使不满足条件,也要把此次数据读完再结束本次,否则直接影响之后的数据读取
#include<stdio.h>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
struct Node{
double s,e;
bool operator<(const Node o)const{
return s < o.s; //按照 区间初始距离升序
}
};
int n,d;
struct Node nodes[1000+5];
int main()
{
int x,y;
int kcase = 0;
//freopen("C:/Users/zhangwei/Desktop/input.txt","r",stdin);
while(cin >> n >> d && n!=0 && d != 0){
bool flag = true;
for(int i = 0; i < n; ++i){
scanf("%d%d",&x,&y);
if(y > d){
flag = false; //注意 不要在这里直接break, 否则本次数据没有读取完
} //影响下一组数据的读取 导致RuntimeError
double t = sqrt(d*d-y*y);
nodes[i].s = x-t;//记录区间
nodes[i].e = x+t;
}
printf("Case %d:",++kcase);
if(!flag){
printf(" -1\n");
continue; //一旦有不可探测点结束
}
sort(nodes,nodes+n);
int firNoVis = 0;
int ans = 1;//初始为1
for(int i = 1; i < n; ++i){
for(int j = firNoVis; j < i; ++j){
if(nodes[i].s <= nodes[j].e){
continue;
}
else{
firNoVis = i;
++ans;
break;
}
}
}
printf(" %d\n",ans);
}
return 0;
}