《ACM程序设计》书中题目R

Description
Prime Number Definition
An integer greater than one is called a prime number if its only positive divisors (factors) are one and itself. For instance, 2, 11, 67, 89 are prime numbers but 8, 20, 27 are not.

Semi-Prime Number Definition
An integer greater than one is called a semi-prime number if it can be decompounded to TWO prime numbers. For example, 6 is a semi-prime number but 12 is not.

Your task is just to determinate whether a given number is a semi-prime number.

Input
There are several test cases in the input. Each case contains a single integer N (2 <= N <= 1,000,000)

Output
One line with a single integer for each case. If the number is a semi-prime number, then output “Yes”, otherwise “No”.

Sample Input
3
4
6
12

Sample Output
No
Yes
Yes
No

求半素数,用打表存一下输出,不然容易超时。

#include<bits/stdc++.h>
using namespace std;
vector<int> v;
set<int> s;
void ChoosePrime(int a,int b)
{
    for(int i=a;i<=b;i++)
    {
        if(i!=2&&i%2==0) 
            continue;
        for(int j=3;j*j<=i;j+=2)
        {
            if(i%j==0) goto RL;
        }
        v.push_back(i);
    RL:continue;
    }
}
int main()
{
    ChoosePrime(2,500000);
    int i,j,p;
    for(i=0;i<v.size();i++)
    {
        for(j=0;j<v.size();j++)
        {
            p=v[i]*v[j];
            if(p<1000000) 
                s.insert(p);
            else 
                break;
        }
    }
    int n;
    set<int>::iterator it;
    while(cin>>n)
    {
        it=s.find(n);
        if(it!=s.end()) 
            cout<<"Yes"<<endl;
        else 
            cout<<"No"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值